Bug 827697 - SELinux is preventing /usr/libexec/totem-plugin-viewer from 'execute' accesses on the file /home/jonas/.orc/orcexec.3J1vXb (deleted).
SELinux is preventing /usr/libexec/totem-plugin-viewer from 'execute' accesse...
Status: CLOSED DUPLICATE of bug 827712
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7ff79e4c97f83fd4b4e27b22b66...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 07:50 EDT by jonasfust
Modified: 2012-06-04 09:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 09:05:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jonasfust 2012-06-02 07:50:16 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Sat 02 Jun 2012 01:49:46 PM CEST

description:
:SELinux is preventing /usr/libexec/totem-plugin-viewer from 'execute' accesses on the file /home/jonas/.orc/orcexec.3J1vXb (deleted).
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that totem-plugin-viewer should be allowed execute access on the orcexec.3J1vXb (deleted) file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep totem-plugin-vi /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:gstreamer_home_t:s0
:Target Objects                /home/jonas/.orc/orcexec.3J1vXb (deleted) [ file ]
:Source                        totem-plugin-vi
:Source Path                   /usr/libexec/totem-plugin-viewer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           totem-mozplugin-3.4.1-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21
:                              22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Sat 02 Jun 2012 01:43:02 PM CEST
:Last Seen                     Sat 02 Jun 2012 01:48:46 PM CEST
:Local ID                      faf3bc68-7713-4408-92d4-844d32cdf86d
:
:Raw Audit Messages
:type=AVC msg=audit(1338637726.14:205): avc:  denied  { execute } for  pid=25077 comm="totem-plugin-vi" path=2F686F6D652F6A6F6E61732F2E6F72632F6F7263657865632E334A31765862202864656C6574656429 dev="dm-2" ino=2360818 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:gstreamer_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338637726.14:205): arch=x86_64 syscall=mmap success=no exit=EACCES a0=0 a1=10000 a2=5 a3=1 items=0 ppid=1 pid=25077 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=totem-plugin-vi exe=/usr/libexec/totem-plugin-viewer subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-plugin-vi,mozilla_plugin_t,gstreamer_home_t,file,execute
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-06-04 09:05:16 EDT

*** This bug has been marked as a duplicate of bug 827712 ***

Note You need to log in before you can comment on or make changes to this bug.