Bug 827714 - /etc/sysconfig/dirsrv does not work for setting keytabs (need instance specific)
/etc/sysconfig/dirsrv does not work for setting keytabs (need instance specific)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: 389-ds-base (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 11:50 EDT by Edward Z. Yang
Modified: 2012-06-16 14:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 15:46:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Z. Yang 2012-06-02 11:50:33 EDT
In the current /etc/sysconfig/dirsrv documentation, there is the following block:

# In order to use SASL/GSSAPI (Kerberos) the directory
# server needs to know where to find its keytab
# file - uncomment the following line and set
# the path and filename appropriately
# if using systemd, omit the "; export VARNAME" at the end
# KRB5_KTNAME=/etc/dirsrv/myname.keytab ; export KRB5_KTNAME

However, uncommenting this line and specifying the keytab appropriately doesn't work; instead, you need to set KRB5_KTNAME the instance specific systemd file e.g. /etc/sysconfig/dirsrv-scripts for the dirsrv to pick up the keytab.

There is also another odd little bug where if /etc/sysconfig/dirsrv is missing, there is an LD_PRELOAD error looking for the Solaris /usr/lib/libumem.so
Comment 1 Rich Megginson 2012-06-15 15:46:05 EDT
Hmm - works for me:

/etc/sysconfig/dirsrv:
...
KRB5_KTNAME=/etc/dirsrv/myname.keytab
...
RANDOM_ENV_VAR=1
...

start directory server using systemctl start dirsrv.target

ps -ef|grep slapd

cat /proc/pid-of-slapd/environ | tr '\0' '\n'
...
KRB5_KTNAME=/etc/dirsrv/myname.keytab
...
RANDOM_ENV_VAR=1
...
Comment 2 Edward Z. Yang 2012-06-16 14:59:07 EDT
Hm, in that case, the bug probably was me forgetting to follow the instructions 'if using systemd, omit the "; export VARNAME" at the end'.

Note You need to log in before you can comment on or make changes to this bug.