Bug 827727 - KDE logout poweroff/restart options do not function
KDE logout poweroff/restart options do not function
Status: CLOSED DUPLICATE of bug 820675
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 13:01 EDT by Russ
Modified: 2012-06-02 15:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-02 13:08:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russ 2012-06-02 13:01:15 EDT
Description of problem:
When logging out of KDE the poweroff/restart options do not function.

Version-Release number of selected component (if applicable):
4.8.3-1

How reproducible:
always

Steps to Reproduce:
1. attempt to poweroff/restart the computer using KDE logoff buttons

Actual results:
computer drops to the shell but does not poweroff or restart

Expected results:
computer drops to the shell then does poweroff or restart

Additional info:
Had no problems with poweroff/restart in F16.

This problem occurs for me when using startx. The poweroff/restart buttons worked in F16. So no excuses like "you need to be using kdm" are valid. If it is not supposed to work the buttons should not even show up.

Too many bugs in F17 so far for me to attempt installing F17 on my other system which uses KDM and see if it works there. Would be a big problem if it did not.

Need addtl. comments from someone using kdm.
Comment 1 Kevin Kofler 2012-06-02 13:08:10 EDT
Nothing we can do about this in KDE, startx does not work with the new systemd-logind session registration in F17, see the already reported bug.

*** This bug has been marked as a duplicate of bug 820675 ***
Comment 2 Kevin Kofler 2012-06-02 13:09:55 EDT
And if those buttons are showing up even though you are not allowed to shutdown/restart, that's also a systemd-logind bug. We display them only if systemd says you can shutdown.
Comment 3 Andrew Travneff 2012-06-02 15:06:17 EDT
(In reply to comment #2)
> And if those buttons are showing up even though you are not allowed to
> shutdown/restart

Yes, they are all shown, but just log out, no restart/poweroff. I have this too, as well as #820675.

Note You need to log in before you can comment on or make changes to this bug.