Bug 827753 - Menus aligned to the left on second monitor
Menus aligned to the left on second monitor
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 16:30 EDT by Ian Pilcher
Modified: 2012-06-20 06:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 06:03:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 46469 None None None 2012-06-20 05:00:26 EDT
FreeDesktop.org 49650 None None None 2012-06-02 16:30:15 EDT
Launchpad 952325 None None None 2012-06-02 16:45:02 EDT

  None (edit)
Description Ian Pilcher 2012-06-02 16:30:15 EDT
This is already filed upstream as FDO #49650.  Opening this, since the upstream bug doesn't seem to be getting any attention, despite being bisected.

Here is the description from the upstream bug:

Problem description: On CentOS 6.2 (KDE 4.3.4), LibreOffice windows on the
second monitor open all menus (incl. context menus) to the *LEFT* instead of to
the *RIGHT*. This results in sub-menus opening *over* parent the menu instead
of to the right (see attached screenshot).
This has been reported so far for Ubuntu as well
(https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/952325).

Steps to reproduce:
1. Open LibreOffice on the second monitor
2. Click for any menu (e.g., File)
3. The menu is aligned to the left instead of to the right

Current behavior:
Menus aligned to the left on second monitor

Expected behavior:
Menus aligned to the right on the second monitor as they do on the primary
monitor (and all other applications, including OpenOffice 3.2 on the same
machine & OS).

Platform (if different from the browser): 
CentOS 6.2 KDE 4.3.4              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.4) Gecko/20120425
Firefox/10.0.4
Comment 1 Ian Pilcher 2012-06-02 16:44:10 EDT
BTW, the problem appears to have been introduced by this giant commit:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a39f4e5b57f5e518cc1ba09d5801da07b52fbaa5
Comment 2 David Tardon 2012-06-20 06:03:18 EDT
the fix will be in 3.5.5 upstream release, so we will wait for it

Note You need to log in before you can comment on or make changes to this bug.