Bug 827777 - Wine32 on 64 bits system : dri issue with f17
Wine32 on 64 bits system : dri issue with f17
Status: CLOSED DUPLICATE of bug 827776
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 21:37 EDT by Romain DEP.
Modified: 2012-06-02 21:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-02 21:46:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Romain DEP. 2012-06-02 21:37:35 EDT
Description of problem:

(I'm running wine.i686 on top of a f17 x86_64 system.)

After having installed a fresh f17 I noticed that some games that previously worked well under wine on f16 were having issues :

err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "Mesa DRI Mobile Intel\xc2\xae GM45 Express Chipset ", version "1.4 (2.1 Mesa 8.0.3)").

even if my system DOES direct rendering...

So I looked at this : http://www.winehq.org/pipermail/wine-users/2010-February/067958.html it's like wine requires 32b versions of the mesa drivers. So I installed mesa-dri-drivers.i686 and hopefully tried a "export LIBGL_DRIVERS_PATH=/usr/lib/dri/" and... ourrah, my game was working. I'm not sure about if the path override is really needed, but shouldn't wine.i686 come with the mesa-dri-drivers.i686 package for 3D-things to work ?

Just asking, thanks !

Romain.
Comment 1 Romain DEP. 2012-06-02 21:46:10 EDT
Duplicate because a server error occurred, sorry for the noise :)

*** This bug has been marked as a duplicate of bug 827776 ***

Note You need to log in before you can comment on or make changes to this bug.