Bug 827841 - [abrt] ibus-1.4.99.20120428-2.fc17: enginetreeview.py:120:__icon_cell_data_cb:AttributeError: 'NoneType' object has no attribute 'get_icon'
[abrt] ibus-1.4.99.20120428-2.fc17: enginetreeview.py:120:__icon_cell_data_cb...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:3bd5f8258a9f7da871e0389c796...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 04:57 EDT by youzhihong
Modified: 2012-08-11 07:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 22:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description youzhihong 2012-06-03 04:57:01 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/share/ibus/setup/main.py ibus-setup
executable:     /usr/share/ibus/setup/main.py
kernel:         3.3.7-1.fc17.i686.PAE
time:           2012年06月03日 星期日 16时55分52秒
uid:            1000

backtrace:
:enginetreeview.py:120:__icon_cell_data_cb:AttributeError: 'NoneType' object has no attribute 'get_icon'
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/setup/enginetreeview.py", line 120, in __icon_cell_data_cb
:    pixbuf = load_icon(engine.get_icon(), Gtk.IconSize.LARGE_TOOLBAR)
:AttributeError: 'NoneType' object has no attribute 'get_icon'
:
:Local variables in innermost frame:
:engine: None
:self: <EngineTreeView object at 0x9576284 (EngineTreeView at 0x970a080)>
:celllayout: <TreeViewColumn object at 0x98336e4 (GtkTreeViewColumn at 0x95ba208)>
:it: <GtkTreeIter at 0x9884e20>
:renderer: <CellRendererPixbuf object at 0x983393c (GtkCellRendererPixbuf at 0x94e5548)>
:icon_size: True
:model: <ListStore object at 0x9576144 (GtkListStore at 0x95cb760)>
:data: None
Comment 1 fujiwara 2012-06-03 22:28:52 EDT
I cannot reproduce your problem.
Di you see your problem with the latest ibus?

# yum install --enablerepo=updates-testing ibus
Comment 2 fujiwara 2012-07-23 22:53:01 EDT
If you still reproduce your problem, please comment it here.
Comment 3 stonewen@gmail.com 2012-08-11 07:59:43 EDT
in gnome 3 fallback mode,with the latest ibus,i meet the same error.i am upated form f15 with preupdate,this error occur after updated

Note You need to log in before you can comment on or make changes to this bug.