Bug 827846 - nfsd return unexpected code when conflicting delegation
nfsd return unexpected code when conflicting delegation
Status: CLOSED DUPLICATE of bug 823018
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: nfs-maint
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 05:20 EDT by Jian Li
Modified: 2014-03-03 19:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-03 23:47:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jian Li 2012-06-03 05:20:00 EDT
Description of problem:
When testing with pynfs, one of the case failed, IMO, the case try to break delegation, and got unexpected return code. I am testing on 2.6.32-277.el6.

> 564 def testLink(t, env):
> 565     """DELEGATION test
> 566
> 567     Get read delegation, then ensure LINK recalls it.
> 568     Respond properly and send DELEGRETURN.
> 569
> 570     FLAGS: delegations
> 571     CODE: DELEG15b
> 572     """
> 573     c = env.c1
> 574     count = c.cb_server.opcounts[OP_CB_RECALL]
> 575     c.init_connection('pynfs%i_%s' % (os.getpid(), t.code), cb_ident=0)
> 576     _get_deleg(t, c, c.homedir + [t.code], _recall, NFS4_OK)
> 577     ops = c.use_obj(c.homedir + [t.code]) + [c.savefh_op()];
> 578     ops += c.use_obj(c.homedir) + [c.link_op(t.code + '.link')];
> 579     _retry_conflicting_op(env, c, ops, "link")   #after got write delegation, link operation breaks the delegation on server. and NFSERR_OK or NFSERR_DELAY should be returned, in fact, NFSERR_NOENT is returned.
> 580     _verify_cb_occurred(t, c, count)
>
> test result:
> **************************************************
> DELEG15b st_delegation.testLink                                   : FAILURE
>            link which causes recall should return NFS4_OK or
>            NFS4ERR_DELAY, instead got NFS4ERR_NOENT
> **************************************************
>
> detailed result:
> COMPOUND4args(tag='', minorversion=0, argarray=[nfs_argop4(argop=OP_PUTROOTFH), nfs_argop4(argop=OP_LOOKUP, oplookup=LOOKUP4args(objname='tmp')), nfs_argop4(argop=OP_LOOKUP, oplookup=LOOKUP4args(objname='DELEG15b')), nfs_argop4(argop=OP_SAVEFH), nfs_argop4(argop=OP_PUTROOTFH), nfs_argop4(argop=OP_LOOKUP, oplookup=LOOKUP4args(objname='tmp')), nfs_argop4(argop=OP_LINK, oplink=LINK4args(newname='DELEG15b.link'))])
> COMPOUND4res(status=NFS4ERR_NOENT, tag='', resarray=[nfs_resop4(resop=OP_PUTROOTFH, opputrootfh=PUTROOTFH4res(status=NFS4_OK)), nfs_resop4(resop=OP_LOOKUP, oplookup=LOOKUP4res(status=NFS4_OK)), nfs_resop4(resop=OP_LOOKUP, oplookup=LOOKUP4res(status=NFS4_OK)), nfs_resop4(resop=OP_SAVEFH, opsavefh=SAVEFH4res(status=NFS4_OK)), nfs_resop4(resop=OP_PUTROOTFH, opputrootfh=PUTROOTFH4res(status=NFS4_OK)), nfs_resop4(resop=OP_LOOKUP, oplookup=LOOKUP4res(status=NFS4_OK)), nfs_resop4(resop=OP_LINK, oplink=LINK4res(status=NFS4ERR_NOENT))])
>  *****CB received COMPOUND******
> ******* CB_Recall (id=1)********

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
pynfs/nfs4.0
  
Actual results:


Expected results:


Additional info:
Comment 1 Jian Li 2012-06-03 05:21:46 EDT
This is fixed upstream by 7d751f6f8.
Comment 4 RHEL Product and Program Management 2012-06-03 21:02:21 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 5 yanfu,wang 2012-06-03 23:40:11 EDT
I think it's duplicated with bug 823018, see https://bugzilla.redhat.com/show_bug.cgi?id=823018#c1.
Comment 6 Jian Li 2012-06-03 23:47:42 EDT

*** This bug has been marked as a duplicate of bug 823018 ***

Note You need to log in before you can comment on or make changes to this bug.