Bug 827849 - Can't connect to mobile broadband with Huawei Stick
Can't connect to mobile broadband with Huawei Stick
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 05:52 EDT by firefexx
Modified: 2012-06-13 11:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 11:55:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
NetworkManager and ModemManager debug output (41.88 KB, text/x-log)
2012-06-03 05:52 EDT, firefexx
no flags Details

  None (edit)
Description firefexx 2012-06-03 05:52:28 EDT
Created attachment 588816 [details]
NetworkManager and ModemManager debug output

Description of problem:
GNOME NetworkManager / ModemManager can't connect to mobile broadband network (O2, germany) with a Huawei E1750 USB-modem. The device is listed in NetworkManager but nothing happens when I click the network name to connect.


Version-Release number of selected component (if applicable):
kernel: 3.3.7-1.fc17.x86_64
networkmanager: 1:0.9.4.0-9.git20120521.fc17
modemmanager: 0.5.2.0-1.fc17

How reproducible:
always

Steps to Reproduce:
1. plug in the modem
2. click NetworkManager icon and choose the mobile network
  
Actual results:
tries to connect, then refuse

Expected results:
should connect

Additional info:
just tried debug output as described here: https://live.gnome.org/NetworkManager/Debugging , attached logs
Comment 1 firefexx 2012-06-03 05:58:18 EDT
Maybe it's worth saying that it worked before upgrading F16 to F17.
Comment 2 firefexx 2012-06-10 05:08:49 EDT
Ok, seems that it's not a bug in ModemManager. Just tried a fresh install on a external hdd and the stick works fine. Even after updating. Don't understand the difference compared to my main system...
Comment 3 firefexx 2012-06-13 11:55:56 EDT
Just reinstalled Fedora. Works fine now.

Note You need to log in before you can comment on or make changes to this bug.