Bug 827867 - VMware 8.0.2 PANIC on Fedora 17, Kernel 3.3.7/3.0.0
VMware 8.0.2 PANIC on Fedora 17, Kernel 3.3.7/3.0.0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 07:23 EDT by Philip
Modified: 2013-03-15 08:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 08:45:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip 2012-06-03 07:23:43 EDT
Description of problem (short version):
=======================================

Fedora 17 + VMware Workstation 8.0.2 = VMware PANIC



Description of problem:
=======================

Usually when I updated my system and a new Kernel got installed, VMware would bring up this dialog saying that the modules have to be rebuilt. That never really worked (with new Kernel versions), failing with errors like "Failed to build module vmnet". So I kept booting the Fedora system with an older Kernel (but usually found some patch that made it work with the new Kernel version).

The point is, VMware always recognized that the system was running with a different Kernel and refused to start until its modules have been rebuilt.

Now, on a Fedora 17 system with Kernel 3.3.7, VMware won't even try to rebuild its modules. It'll just start right up. So when starting a virtual machine, VMware panics. By that, I mean it looks like a Linux Kernel panic, whole screen turns black, shows only some useless backtrace. Switching tty (Ctrl+Alt+F3) not possible. SSH daemon still running, so it's possible to log on to the machine remotely and shutdown (> 20 minutes). Issuing something like "ps aux" (over SSH, obviously) will show a little bit of output, then get stuck (same for kill). When rebooting, the system log sometimes shows fsck warnings (inodes repaired), indicating that data loss might have occured.

Since I couldn't find an older Kernel in the Fedora 17 repository, I manually compiled and installed Kernel 3.0.0. However, that doesn't seem to change anything. VMware doesn't recompile any modules by itself. I can't make it do so by removing /usr/lib/vmware/modules/source/.patched, because that file doesn't exist. Running vmware-modconfig --console --install-all does not throw any error, but starting a VM will still cause this VMware panic.

 

Version-Release number of selected component (if applicable):
=============================================================

Fedora 17.
VMware Workstation 8.



How reproducible:
=================

VMware PANIC happens every time a VM is started.



Steps to Reproduce:
===================

1. Install new Fedora 17 system.
2. Install VMware dependencies (yum install gcc-c++ make kernel-headers).
3. Install VMware Workstation 8.0.2.
4. Run it (vmware) and start any virtual machine.



Actual results:
===============

VMware starts right up (without rebuilding its modules) and causes a PANIC, which renders the system unusable until reboot and might even cause data loss (running GUI programs cannot be exited anymore and, according to the system log, partitions aren't even unmounted properly, even when shutting down via SSH).



Expected results:
=================

1. VMware rebuilds its modules on first start (won't start until this has finished).
1.5 This process usually fails (something like "failed to compile module vmnet"), so either find a patch or boot into an older Kernel (<= 3.1), where VMware is able to build its modules.
2. Starting a VM actually starts the VM.



Additional info:
================

I've heard this may be chipset related, so please note that I'm using an AMD processor (AMD Phenom(tm) II X6 1100T).

I've installed Debian Squeeze (Kernel 2.6) on the same computer, installed VMware, mounted the Fedora home partition in Debian so (everything including) VMware uses the same settings (same VMs) like Fedora. On first start, it tried and succeeded to rebuild its modules. Then I started a VM and it worked right away.

Please let me know if you need more information.
Comment 1 Philip 2012-08-07 05:22:08 EDT
IMPORTANT UPDATE:
=================

I have reinstalled Fedora 17 (Kernel 3.5.0-2.fc17.x86-64) with VMware Workstation 8.0.3. It tries (and fails) to build its modules. Then applied a patch (http://www.gigahype.com/install-vmware-workstation-8-fedora-17/).

When starting a virtual machine, I still get a VMware PANIC.
But I did the exact same reinstallation (same Fedora, same Kernel) on another computer with different hardware and it worked there.

So it obviously has something to do with the hardware - in combination with Fedora 17, because this never happened before 17.

Processor: AMD Phenom(tm) II X6 1100T
Mainboard: ASUS SABERTOOTH 990FX
Comment 2 Josh Boyer 2013-03-15 08:45:17 EDT
We don't support VMWare or the out-of-tree VMWare modules.

Note You need to log in before you can comment on or make changes to this bug.