Bug 827871 - ovirt-engine-backend: Actions ran on disks from the disk's sub tab under VM's tab will cause vm to get into image locked
ovirt-engine-backend: Actions ran on disks from the disk's sub tab under VM's...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.0
Assigned To: mkublin
Dafna Ron
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 07:48 EDT by Dafna Ron
Modified: 2016-02-10 12:14 EST (History)
8 users (show)

See Also:
Fixed In Version: SI6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (33.17 KB, application/x-xz)
2012-06-03 07:48 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-03 07:48:30 EDT
Created attachment 588833 [details]
log

Description of problem:

when creating a new disk under the disk sub tab (under the vm tab's) the vm gets into image locked.
since the disks are independent entities we should not lock the vm for actions that only lock the disk. 

Version-Release number of selected component (if applicable):

si4

How reproducible:

100%

Steps to Reproduce:
1. create a new disk using the disk sub tabs under the vm tab
2.
3.
  
Actual results:

vm gets into image locked. 

Expected results:

only the disk should get into image locked
any run or action on the vm entity should be blocked by validation. 

Additional info: backend log
Comment 1 mkublin 2012-06-04 05:24:30 EDT
Solution is : http://gerrit.ovirt.org/#/c/5024/
The same solution is also fort bug https://bugzilla.redhat.com/769885
But the problems is a little bit different
Comment 2 Dafna Ron 2012-06-19 12:23:59 EDT
verified on si6
vm will no longer get into image locked when performing disk tasks.

Note You need to log in before you can comment on or make changes to this bug.