Bug 827876 - Fedora 17 Kernel is not installed after Preupgrade
Fedora 17 Kernel is not installed after Preupgrade
Status: CLOSED DUPLICATE of bug 820351
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Windows
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 08:40 EDT by akvasu@gmail.com
Modified: 2012-06-03 18:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-03 18:09:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description akvasu@gmail.com 2012-06-03 08:40:23 EDT
Description of problem: After pre-upgrade the Fedora 17 kernels are not installed. 


Version-Release number of selected component (if applicable): F16 to F17 , preupgrade version F16, grub 0.97 and gub2 


How reproducible: I tried 4 Pre-Upgrades


Steps to Reproduce:
1. F16 installed and updated to latest (kernel ver 3.3.7-1-fc16.x86_64)
2. Preupgrade, and also tried fix listed in #826537
3. Reboot after Pre-upgrade 
  
Actual results:
Preupgrade sucess
/root/upgrade.log indicated packages installed  - with fix of $826537 log shows 

17:52:03 Upgrading grubby-8.12-1.fc17.x86_64
*** FINISHED INSTALLING PACKAGES ***

Kernel not present - 
[root@localhost ~]# cd /boot/
[root@localhost boot]# ls
config-3.3.2-1.fc16.x86_64         initrd-plymouth.img
config-3.3.6-3.fc16.x86_64         lost+found
config-3.3.7-1.fc16.x86_64         memtest86+-4.20
efi                                System.map-3.3.2-1.fc16.x86_64
elf-memtest86+-4.20                System.map-3.3.6-3.fc16.x86_64
grub                               System.map-3.3.7-1.fc16.x86_64
grub2                              vmlinuz-3.3.2-1.fc16.x86_64
initramfs-3.3.2-1.fc16.x86_64.img  vmlinuz-3.3.6-3.fc16.x86_64
initramfs-3.3.6-3.fc16.x86_64.img  vmlinuz-3.3.7-1.fc16.x86_64
initramfs-3.3.7-1.fc16.x86_64.img
[root@localhost boot]# rpm -q kernel
kernel-3.3.2-1.fc16.x86_64
kernel-3.3.6-3.fc16.x86_64
kernel-3.3.7-1.fc16.x86_64


Expected results:

Expected to see Kernel version 17, 3.3.7-1.fc17
 
Additional info:
Comment 1 akvasu@gmail.com 2012-06-03 08:41:31 EDT
Just want to add, I have a Lenovo W510, with a Nvidia chipset, and a 128gb SSD.
Comment 2 Chris Lumens 2012-06-03 18:09:51 EDT

*** This bug has been marked as a duplicate of bug 820351 ***

Note You need to log in before you can comment on or make changes to this bug.