Bug 827890 - ovirt-engine-backend: rollback on snapshot preview failure did not change the snapshot state in db and image is presented as previewed
ovirt-engine-backend: rollback on snapshot preview failure did not change the...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity urgent
: ---
: 3.1.0
Assigned To: Tal Nisan
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 09:49 EDT by Dafna Ron
Modified: 2016-02-10 11:28 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shots (67.28 KB, application/x-gzip)
2012-06-03 09:49 EDT, Dafna Ron
no flags Details
logs (150.36 KB, application/x-gzip)
2012-06-03 09:51 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-03 09:49:54 EDT
Created attachment 588861 [details]
screen shots

Description of problem:

after failure in preview of snapshot the snapshot appears as previewed in webadmin. 
checking the db snapshot table the status of the image is still IN_PREVIEW

this requires a manual intervention in db since we cannot create any snapshots, commit and undo will fail (since vdsm has rolled back). 

Version-Release number of selected component (if applicable):

si4

How reproducible:

100%

Steps to Reproduce:
1. create 3 domains + vm with 3 disks on each domain
2. create a snapshot
3. put one domain in maintenance -> preview snaoshot
  
Actual results:

action will fail and eventually rollback
image will remain in webadmin as in preview 
db snapshot table shows that the image is in status IN_PREVIEW

Expected results:

we should change image status in db once we rollback

Additional info:logs + screen shot
Comment 1 Dafna Ron 2012-06-03 09:51:36 EDT
Created attachment 588868 [details]
logs
Comment 2 Tal Nisan 2012-06-20 05:00:00 EDT
Could not reproduce in si6, getting the following message:
"    Cannot preview Snapshot. The relevant Storage Domain is inaccessible.
    -Please handle Storage Domain issues and retry the operation."
Can you please recheck?
Comment 3 Tal Nisan 2012-06-20 06:52:01 EDT
Fixed on si6
Comment 4 Dafna Ron 2012-06-20 12:20:19 EDT
verified on si6

Note You need to log in before you can comment on or make changes to this bug.