Bug 827897 - Upgrade of libvirt breaks VDSM (due to broken link in /etc/init/libvirtd.conf)
Upgrade of libvirt breaks VDSM (due to broken link in /etc/init/libvirtd.conf)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Douglas Schilling Landgraf
Haim
infra
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 10:36 EDT by Yaniv Kaul
Modified: 2014-01-12 19:52 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 23:58:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-06-03 10:36:35 EDT
Description of problem:
Upgrade of 6.2.z libvirt (libvirt-0.9.4-23.el6_2.8.x86_64) to 6.3's libvirt (libvirt-0.9.10-21.el6.x86_64) causes a broken link:
/etc/init/libvirtd.conf -> /usr/share/doc/libvirt-0.9.4/libvirtd.upstart

This prevents VDSM from starting.

Workaround:
[root@master-vds11 init]# rm libvirtd.conf 
rm: remove symbolic link `libvirtd.conf'? y
[root@master-vds11 init]# cp /usr/share/doc/libvirt-0.9.10/libvirtd.upstart 

Version-Release number of selected component (if applicable):
libvirt-0.9.10-21.el6.x86_64

How reproducible:
Twice already. On running 6.2.z hypervisors, moved those hosts to maintenance in RHEVM, perform 'yum update' then reboot.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Huang Wenlong 2012-06-04 04:06:14 EDT
Hi , Yaniv 

I know this issue , the cause is your host installed a old version vdsm , 
/etc/init/libvirtd.conf ->  /usr/share/doc/libvirt-0.9.4/libvirtd.upstart  
this soft link it created by old vdsm setup scripts , but new vdsm use "copy" instead of "link" ,so in my host I can not reproduce this bug . 
the bad file is not created by libvirt, so I think it is not a libvirt's bug

version in my host 
libvirt-0.9.4-23.el6_2.8.x86_64
vdsm-4.9-112.8.el6_2.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64

# ll /etc/init/libvirtd.conf  (it is a real file not a link )
-rw-r--r--. 1 root root 991 May 31 22:43 /etc/init/libvirtd.conf


Wenlong
Comment 2 Jiri Denemark 2012-06-04 05:35:59 EDT
I agree that this is not a libvirt bug. The /etc/init/libvirtd.conf link is not created by libvirt. IIRC someone (danpb?) somewhere mentioned that a package (which would be vdsm in this case) can install a script which is executed when another package is upgraded... such script could be used to update the link. However, I don't remember the details and my memory can even be completely wrong...
Comment 3 Dave Allan 2012-06-04 09:14:37 EDT
I'm not at all sure whose BZ this is, but it's most certainly a bug, so I'm reopening.
Comment 4 Dave Allan 2012-06-04 09:23:03 EDT
My initial impression is that VDSM needs to be updated to know about the new libvirt version, so I'm changing the component to VDSM.
Comment 5 Itamar Heim 2012-06-07 03:18:41 EDT
yaniv - if this is still relevant, shouldn't this be a 6.3 blocker for vdsm (even though one can upgrade libvirt without upgrading vdsm)?
raising priority until this is analyzed
Comment 7 Itamar Heim 2012-06-07 05:03:11 EDT
according to danken:
"the softlink was only created in beta cycle of 3.0. no customer should have it (we used copy by GA).
a maybe on a release note in case some customers have upgraded from beta."

moving to ON_QA to check this and close if not reproduced on clean vdsm.
Comment 8 Haim 2012-06-07 11:18:55 EDT
(In reply to comment #7)
> according to danken:
> "the softlink was only created in beta cycle of 3.0. no customer should have
> it (we used copy by GA).
> a maybe on a release note in case some customers have upgraded from beta."
> 
> moving to ON_QA to check this and close if not reproduced on clean vdsm.

Just verified the above by installing clean vdsm build from version vdsm-4.9-112.14, checked /etc/init/ and there was no link to libvirt upstart, then, added rhel6.3 repo, upgraded to vdsm-4.9-113.1.el6.x86_64, then upgraded libvirt, and everything went smooth. 

we shall add a RN.
Comment 9 Itamar Heim 2012-07-18 02:13:00 EDT
*** Bug 841042 has been marked as a duplicate of this bug. ***
Comment 10 Haim 2012-07-18 03:26:04 EDT
moving to verified as per comment 8.

Note You need to log in before you can comment on or make changes to this bug.