Bug 827904 - SELinux is preventing /usr/bin/python2.7 from 'execute' accesses on the file /usr/sbin/wpa_cli.
SELinux is preventing /usr/bin/python2.7 from 'execute' accesses on the file ...
Status: CLOSED DUPLICATE of bug 827905
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b3e8377e2d6acfb7d7840922b65...
:
: 827902 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 11:49 EDT by Jake Jackson
Modified: 2012-06-04 06:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 06:51:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jake Jackson 2012-06-03 11:49:59 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Sun 03 Jun 2012 05:49:45 PM CEST

description:
:SELinux is preventing /usr/bin/python2.7 from 'execute' accesses on the file /usr/sbin/wpa_cli.
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If you want to ignore python2.7 trying to execute access the wpa_cli file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /usr/bin/python2.7 /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed execute access on the wpa_cli file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep wicd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:NetworkManager_t:s0
:Target Context                system_u:object_r:wpa_cli_exec_t:s0
:Target Objects                /usr/sbin/wpa_cli [ file ]
:Source                        wicd
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-6.fc17.x86_64
:Target RPM Packages           wpa_supplicant-1.0-0.4.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21
:                              22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   5
:First Seen                    Sun 03 Jun 2012 05:47:55 PM CEST
:Last Seen                     Sun 03 Jun 2012 05:49:21 PM CEST
:Local ID                      1555c5fb-2469-416c-bf11-830c55748ff3
:
:Raw Audit Messages
:type=AVC msg=audit(1338738561.706:406): avc:  denied  { execute } for  pid=30751 comm="wicd" name="wpa_cli" dev="sda1" ino=149896 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:wpa_cli_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338738561.706:406): arch=x86_64 syscall=execve success=no exit=EACCES a0=7fb45c002810 a1=7fb45c0038d0 a2=7fb45c0040e0 a3=3d72542306 items=0 ppid=30351 pid=30751 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=wicd exe=/usr/bin/python2.7 subj=system_u:system_r:NetworkManager_t:s0 key=(null)
:
:Hash: wicd,NetworkManager_t,wpa_cli_exec_t,file,execute
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-06-04 06:42:55 EDT
*** Bug 827902 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-06-04 06:51:31 EDT

*** This bug has been marked as a duplicate of bug 827905 ***

Note You need to log in before you can comment on or make changes to this bug.