Bug 827907 - [abrt] yum-3.4.3-23.fc17: optparse.py:1602:print_usage:UnicodeEncodeError: 'ascii' codec can't encode character u'\xe4' in position 79: ordinal not in range(128)
[abrt] yum-3.4.3-23.fc17: optparse.py:1602:print_usage:UnicodeEncodeError: 'a...
Status: CLOSED DUPLICATE of bug 819229
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:01f2faea729ee0cfaed73f49610...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 11:58 EDT by Jonas Jonsson
Modified: 2014-01-21 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 03:51:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonas Jonsson 2012-06-03 11:58:43 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list installed --aut
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.3.7-1.fc17.x86_64
time:           sön  3 jun 2012 17:57:11
uid:            500
username:       jonas

backtrace:
:optparse.py:1602:print_usage:UnicodeEncodeError: 'ascii' codec can't encode character u'\xe4' in position 79: ordinal not in range(128)
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 81, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 75, in main
:    base.getOptionsConfig(args)
:  File "/usr/share/yum-cli/cli.py", line 287, in getOptionsConfig
:    (opts, self.cmds) = self.optparser.setupYumConfig(args=args)
:  File "/usr/share/yum-cli/cli.py", line 1903, in setupYumConfig
:    (opts, cmds) = self.parse_args(args=args)
:  File "/usr/lib64/python2.7/optparse.py", line 1401, in parse_args
:    self.error(str(err))
:  File "/usr/share/yum-cli/cli.py", line 1853, in error
:    self.print_usage()
:  File "/usr/lib64/python2.7/optparse.py", line 1602, in print_usage
:    print >>file, self.get_usage()
:UnicodeEncodeError: 'ascii' codec can't encode character u'\xe4' in position 79: ordinal not in range(128)
:
:Local variables in innermost frame:
:self: <cli.YumOptionParser instance at 0x7f73aae45440>
:file: None

comment:
:Tried to tabcomplete sudo yum remove --r
:
:Using sv_SE as locale.
Comment 1 Zdeněk Pavlas 2012-06-04 03:51:53 EDT

*** This bug has been marked as a duplicate of bug 819229 ***

Note You need to log in before you can comment on or make changes to this bug.