Bug 827909 - Installing LXDE spin from live CD won't boot when installing grub in boot sector of boot partition instead of MBR
Installing LXDE spin from live CD won't boot when installing grub in boot sec...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: LiveCD - LXDE (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Christoph Wickert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 12:20 EDT by Juan
Modified: 2012-06-05 17:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 13:24:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan 2012-06-03 12:20:06 EDT
Description of problem:
I installed LXDE spin into my netbook (an Asus eee PC 1011PX) from the live image (loaded from a pendrive) and chose to install grub in the boot sector of the boot (active) partition instead of the default MBR.
It didn't boot. It complained about "partition not found" or "file not found". I tried several times and the message was almost the same, but not exactly.

Version-Release number of selected component (if applicable):
Fedora 17 LXDE spin live image.

How reproducible:

Install the LXDE spin choosing boot sector for grub installation and try to boot from hard drive.

For more detailed information, I maually (fdisk) partitioned the only had drive in three classical MBR primary partitions (no GPT partition used): A 500 Mb one for boot partition, a 4 Gb one for swap and the rest for root partition. I activated the first (500Mb) partition.
I also chose to encrypt swap and root partitions.

Steps to Reproduce:
1. Install Fedora 10 LXDE spin live image into an USB pendrive
2. Boot an Asus eee PC 1011PX from that pendrive.
3. Install to hard disk
4. Select custom partitioning.
5. Select to format 500Mb partition in ext4 without encryption
6. Select to format 4Gb partition for swap with encryption.
7. Select to format root partition in ext4 with encryption.
8. Select to install grub in the boot sector of the boot partition
9. After installation, reboot.
  
Actual results:
Grub loads but complains about partition (or file) not found, does not boot and provides a recovery prompt (I don't know how to use).

Expected results:
System boots up normally

Additional info:
Installing grub in MBR fixed the problem.
I guess this would happen in more general situations, but I preferred to provide every detail on the way I installed my system.
In fact, in my main (tower) computer, I installed the standard Fedora distrib from DVD choosing boot sector for grub and it boots (with another problem about font file "True", already reported in another bug).
Comment 1 Christoph Wickert 2012-06-03 12:39:35 EDT
I doubt this has anything to do with LXDE or the LXDE Live media. Please test that you don't have the same problem with the default "Desktop" spin.
Comment 2 Christoph Wickert 2012-06-03 12:40:37 EDT
And please give me the output of 'fdisk -l /dev/sda' on the affected netbook.
Comment 3 Juan 2012-06-03 12:48:27 EDT
Yes, I really wasn't sure at all where to post this bug, LXDE, anaconda, grub...
But I only tested default Desktop from DVD in another computer and it worked.

I really don't feel like reinstalling a different spin again, as I already took my time configuring it (and it just works now ;)

But as soon as I'm in front of my netbook, I'll send you the output of fdisk and any other information you might need.

Please, feel free to reassing the bug to another area if you consider it has nothing to do with LXDE and sorry if this is the case.
Comment 4 Christoph Wickert 2012-06-03 12:54:49 EDT
I cannot reassign it before this bug before it was verified. This means someone needs to test that it was does not happen with the default spin and was no heisenbug either.

Fedora is a volunteer effort and I am a volunteer packager who maintains ~150 packages. I do not have the time to verify this bug and therefor need to rely on bug reporters to help me.
Comment 5 Juan 2012-06-03 13:00:24 EDT
I understand perfectly and I'll try to find time to test that, but I don't know when I'll be able to do it as I'm really busy.
I wish I had more time to help more, but I do what I can. In fact, installing grub in MBR makes it work for me and it isn't such a big deal. I just wanted to inform about this bug to help others, not for my own benefit.
Don't doubt as long and as soon as I'm able, I'll do all the testing you ask for. And I beg your pardon if I can't.
Thanks for your help and effort.
Comment 6 Juan 2012-06-03 17:54:59 EDT
Well, for the moment:

sudo fdisk -l /dev/sda

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, 625142448 sectores en total
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificador del disco: 0x0007b864

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1   *        2048     1026047      512000   83  Linux
/dev/sda2         1026048     9414655     4194304   82  Linux swap / Solaris
/dev/sda3         9414656   625142447   307863896   83  Linux
Comment 7 Fedora Update System 2012-06-03 19:12:33 EDT
openbox-3.5.0-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openbox-3.5.0-6.fc17
Comment 8 Christoph Wickert 2012-06-03 19:20:28 EDT
Sorry, the openbox update has nothing to do with this update, I accidentally added the wrong number.

Meanwhile I tried to reproduce your problem. I failed both with the desktop media and the LXDE spin. I am going to try one more time with a fresh drive and all default settings.
Comment 9 Christoph Wickert 2012-06-05 13:24:28 EDT
I cannot reproduce your problem, not matter what I try. Please file a new bug against anaconda once you found out how to reliably reproduce your problem. /root/anaconda-ks.cfg might have some information.
Comment 10 Juan 2012-06-05 17:35:47 EDT
Ok, I will, though I'm afraid it might be a combination of hardware/software that won't be reproducible by others unless they have my same netbook (or one with the same problem).
Thanks for your effort,

Juan

Note You need to log in before you can comment on or make changes to this bug.