Bug 827912 - boinc client does not start
Summary: boinc client does not start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: boinc-client
Version: 17
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Milos Jakubicek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-03 16:34 UTC by Juan
Modified: 2012-07-13 14:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-11 23:55:55 UTC


Attachments (Terms of Use)

Description Juan 2012-06-03 16:34:30 UTC
Description of problem:
I installed boinc-client and boinc-manager packages, exactly as I did in previous versions of Fedora.
boinc client refuses to start. Looks like in fact there are no files to start the service (there's no /etc/init.d/boinc-client file neither boinc-client.service). Neither systemctl start boinc-client.service nor service boinc-client start work. Both complain about not finding the file. Obviously boinc-manager can't start the client either (this is the first thing I noticed) and no key is created in /var/lib/boinc.

Version-Release number of selected component (if applicable):
boinc-manager-6.12.43-1.r25218svn.fc17.x86_64
boinc-client-6.12.43-1.r25218svn.fc17.x86_64

How reproducible:
Just installing those two pakages and trying to start the client. Boinc just dose not work.

Steps to Reproduce:
1. Install boinc-manager and boinc-client
2. Just in case, reboot.
3. Try to see the status of boinc-client, or to start it, or to use boinc manager.
  
Actual results:
boinc client doesn't start. There are no corresponding files to start it neither with systemctl nor with service. boinc manager does not work as it can't start boinc client. No boinc key is generated in /var/lib/boinc.

Expected results:
boinc client starts normally (and automatically on boot), boinc manager works and there is a key generated in /var/lib/boinc.

Additional info:

Comment 1 Andris Pavenis 2012-06-03 20:13:23 UTC
I'm getting on 2 systems (one fresh install, one upgraded using preupgrade):

[root@ap ~]# service boinc-client start
Redirecting to /bin/systemctl  start boinc-client.service
Failed to issue method call: Unit boinc-client.service failed to load: No such file or directory. See system logs and 'systemctl status boinc-client.service' for details.

Nothing in /var/log/messages

[root@ap ~]# ls -l /usr/lib/systemd/system/boinc-client 
-rwxr-xr-x. 1 root root 345 Feb  8 16:14 /usr/lib/systemd/system/boinc-client

(I do not though know why it is executable)

Comment 2 Hakan Duran 2012-06-10 22:20:11 UTC
When I restored the /etc/init.d/boinc-client from a back up, things started to work as expected (please see http://forums.fedoraforum.org/showthread.php?t=280933). I believe the rpm package for boinc-client is defective.

Comment 3 Hakan Duran 2012-06-10 22:22:20 UTC
Please excuse the incorrect link in my previous comment. The correct link is http://forums.fedoraforum.org/showthread.php?t=280935. I am sorry for this mistake.

Comment 4 Fedora Update System 2012-06-22 15:39:00 UTC
boinc-client-6.12.43-2.r25218svn.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/boinc-client-6.12.43-2.r25218svn.fc17

Comment 5 Juan 2012-06-23 16:49:01 UTC
Same problem with this new verion (at least for me).

Comment 6 Milos Jakubicek 2012-06-24 18:11:24 UTC
Are you saying that the following:

systemctl start boinc-client.service

still errors for you? I can't really believe that, also because of others that confirmed the issue is now fixed.

Comment 7 Juan 2012-06-24 19:16:15 UTC
rpm -qa|grep boinc-client
boinc-client-6.12.43-1.r25218svn.fc17.x86_64

sudo systemctl start boinc-client.service
Failed to issue method call: Unit boinc-client.service failed to load: No such file or directory. See system logs and 'systemctl status boinc-client.service' for details.

May be something went wrong when upgrading... I'll try to force reinstall of the package...

Comment 8 Juan 2012-06-24 19:24:38 UTC
Oh, dear, I didn't notice the 43-1 instead of 43-2 in version.
Has it been submitted to rawhide may be? I haven't it active right now...

Comment 9 Juan 2012-06-24 20:48:19 UTC
Ok, I enable in gpk-application the testing repository and I didn't get the new version either.
I manually downloaded the rpm's and installed them. Now boinc-client starts, but I get a complain from SELinux:

--------------------------------------------------------

SELinux is preventing /usr/bin/boinc_client from read access on the lnk_file stdoutdae.txt.

*****  Plugin catchall (100. confidence) suggests  ***************************

If cree que de manera predeterminada, boinc_client debería permitir acceso read sobre  stdoutdae.txt lnk_file.     
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
Do
permita el acceso momentáneamente executando:
# grep boinc_client /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:boinc_t:s0
Target Context                system_u:object_r:boinc_var_lib_t:s0
Target Objects                stdoutdae.txt [ lnk_file ]
Source                        boinc_client
Source Path                   /usr/bin/boinc_client
Port                          <Desconocido>
Host                          mallorn.farre.nom
Source RPM Packages           boinc-client-6.12.43-2.r25218svn.fc17.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-132.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     mallorn.farre.nom
Platform                      Linux mallorn.farre.nom 3.4.3-1.local.fc17.x86_64
                              #1 SMP Sat Jun 23 20:41:17 CEST 2012 x86_64 x86_64
Alert Count                   5
First Seen                    dom 24 jun 2012 22:35:22 CEST
Last Seen                     dom 24 jun 2012 22:35:27 CEST
Local ID                      12a47b8a-ac14-4ba0-88ed-027d272e6372

Raw Audit Messages
type=AVC msg=audit(1340570127.980:379): avc:  denied  { read } for  pid=13073 comm="boinc_client" name="stdoutdae.txt" dev="md1" ino=125043310 scontext=system_u:system_r:boinc_t:s0 tcontext=system_u:object_r:boinc_var_lib_t:s0 tclass=lnk_file


type=SYSCALL msg=audit(1340570127.980:379): arch=x86_64 syscall=stat success=no exit=EACCES a0=7fc80eaf7e40 a1=7fffb84f94d0 a2=7fffb84f94d0 a3=63 items=0 ppid=1 pid=13073 auid=4294967295 uid=990 gid=983 euid=990 suid=990 fsuid=990 egid=983 sgid=983 fsgid=983 tty=(none) ses=4294967295 comm=boinc_client exe=/usr/bin/boinc_client subj=system_u:system_r:boinc_t:s0 key=(null)

Hash: boinc_client,boinc_t,boinc_var_lib_t,lnk_file,read

audit2allowunable to open /sys/fs/selinux/policy:  Permission denied


audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied

-------------------------------------------------------------------

Sorry for the parts in Spanish. If you need translation, feel free to ask for it.

Comment 10 Milos Jakubicek 2012-06-25 08:33:08 UTC
Thanks. I'm aware of the SELinux issue, will be fixed today.

Comment 11 Fedora Update System 2012-06-26 00:38:38 UTC
Package boinc-client-6.12.43-2.r25218svn.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing boinc-client-6.12.43-2.r25218svn.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9859/boinc-client-6.12.43-2.r25218svn.fc17
then log in and leave karma (feedback).

Comment 12 Robert Kief 2012-07-05 04:05:17 UTC
I have been working with Kathryn at The BOINC FAQ Service on this problem.  She suggested that I report the bug here (Red Hat Bugzilla).  The problem at BOINC FAQ Service is titled "Disconnected boinc manager in fedora 17" and located here:  http://boinc.berkeley.edu/dev/forum_thread.php?id=7622

I now have BOINC working on my Fedora 17 machine with one notable exception.  I cannot autostart the client.  The command line "systemctl enable boinc-client.service" doesn't autostart boinc-client.  I have to manually start the client with "systemctl start boinc-client.service".

The Fedora 17 installation instructions (located here:  http://boinc.berkeley.edu/wiki/Installing_BOINC_on_Fedora) are not completely accurate.  Also, the missing script indicated in the responses at BOINC FAQ Service was not needed in my case.  Renaming "boinc-client" as installed by yum (su -c 'yum install boinc-client boinc-manager') to "boinc-client.service" was needed however.

Should the boinc-client update indicated in comment 11 fix my autostart problem also?

Comment 13 Milos Jakubicek 2012-07-10 05:40:29 UTC
It should fix starting the client manually, starting it automatically on boot will be fixed by the next update, you might try:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4229099

Comment 14 Fedora Update System 2012-07-11 23:55:55 UTC
boinc-client-7.0.29-1.r25790svn.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Robert Kief 2012-07-13 14:55:51 UTC
Client now autostarts after a reset.  The command string "pgrep -l boinc" returns "837 boinc" and "838 boinc_client".

However, there is still a bit of an issue.  When I run Manager after a restart, I get a "Could not connect to client" error window with the following message:

"The BOINC manager could not connect to BOINC client.  The client might not be running or your (sic) not allowed to connect to it.  Please refer to the documentation provided by the link below to learn how to setup the client."

The link is on "How to use BOINC on Fedora".

The message on the bottom right of the Manager window indicates the client is "disconnected".  Closing the error window results in Manager communicating with client.

Every time I start Manager, I get the same error window.  This error window occurs even if I already have Manager running and open a second interation.

RLK


Note You need to log in before you can comment on or make changes to this bug.