Bug 827922 - RFE: please add image insertion patch
RFE: please add image insertion patch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xournal (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 15:41 EDT by Jonathan Underwood
Modified: 2016-01-31 20:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 18:55:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2012-06-03 15:41:01 EDT
Description of problem:
There's a mature patch available which adds the ability to insert images into documents. Feature addition to xournal seems to have stopped as the authors are working on xournal++, but it would be really helpful to add this patch to the Fedora packages:

http://sourceforge.net/tracker/?func=detail&aid=2987520&group_id=163434&atid=827735

It's be great to have this on all active branches.
Comment 1 Jaromír Cápík 2012-06-04 07:19:50 EDT
Hello Jonathan.

In case of stable Fedora releases updates should only aim to fix bugs, and not introduce new features. But as the patch also fixes some issues, we may do an exception here. Anyway ... first we need to check if the patch is applicable to our current version 0.4.5 ... the latest available version is 0.4.6.
I'll let you know once I have any info for you.

Regards,
Jaromir.
Comment 2 Jaromír Cápík 2012-06-04 12:10:07 EDT
Hello Jonathan.

Denis Auroux just confirmed he's going to merge the image patch into the upstream sources (probably this summer) and therefore I believe we can introduce it in v0.4.5 and then update to v0.4.7 in Rawhide.

Regards,
Jaromir.
Comment 3 Jonathan Underwood 2012-06-05 05:39:13 EDT
Hi Jaromir,

The patch does apply to 0.45 - I've been running a patched version of the package locally on f16 and it works fine. 

As an aside, I note that the 0.46 release is a bugfix release, and so it might be worth pushing that for f17 as well (with the image patch).
Comment 4 Jaromír Cápík 2012-07-09 13:20:10 EDT
I just tested the patch ... the change seems to be stable enough for inclusion in F17 and F16.
Comment 5 Fedora Update System 2012-07-09 14:22:32 EDT
xournal-0.4.5-19.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xournal-0.4.5-19.fc17
Comment 6 Fedora Update System 2012-07-09 14:22:41 EDT
xournal-0.4.5-19.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xournal-0.4.5-19.fc16
Comment 7 Fedora Update System 2012-07-10 12:24:34 EDT
Package xournal-0.4.5-19.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xournal-0.4.5-19.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10424/xournal-0.4.5-19.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-08-15 18:55:14 EDT
xournal-0.4.5-19.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-08-15 18:55:52 EDT
xournal-0.4.5-19.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.