Bug 827930 - [abrt] nautilus-3.4.2-5.fc17: g_utf8_offset_to_pointer: Process /usr/bin/nautilus was killed by signal 11 (SIGSEGV)
[abrt] nautilus-3.4.2-5.fc17: g_utf8_offset_to_pointer: Process /usr/bin/naut...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
abrt_hash:80dbd771184c56342172d2deaaf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 17:03 EDT by chrys87
Modified: 2015-03-03 18:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 09:26:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (23.87 KB, text/plain)
2012-06-03 17:03 EDT, chrys87
no flags Details
File: maps (42.33 KB, text/plain)
2012-06-03 17:03 EDT, chrys87
no flags Details
File: dso_list (13.94 KB, text/plain)
2012-06-03 17:03 EDT, chrys87
no flags Details
File: build_ids (5.77 KB, text/plain)
2012-06-03 17:03 EDT, chrys87
no flags Details

  None (edit)
Description chrys87 2012-06-03 17:03:04 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        nautilus -n
crash_function: g_utf8_offset_to_pointer
executable:     /usr/bin/nautilus
kernel:         3.3.7-1.fc17.i686.PAE
pid:            1158
pwd:            /home/chrys
time:           So 03 Jun 2012 22:54:21 CEST
uid:            1000
username:       chrys
xsession_errors: ** (nautilus:1158): WARNING **: Can not determine workarea, guessing at layout

backtrace:      Text file, 24446 bytes
build_ids:      Text file, 5904 bytes
dso_list:       Text file, 14279 bytes
maps:           Text file, 43344 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/chrys/2

core_backtrace:
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x72e20 g_utf8_offset_to_pointer libglib-2.0.so.0 -
:ad9e27665744b5e0f27506032bcfd11acc11a16c 0x3300de - libgtk-3.so.0 -
:2db83a4c3dc4ba607b77e73639ac847081193f8c 0x11754 atk_text_get_character_extents libatk-1.0.so.0 -
:2db83a4c3dc4ba607b77e73639ac847081193f8c 0x117bf - libatk-1.0.so.0 -
:2db83a4c3dc4ba607b77e73639ac847081193f8c 0x12038 atk_text_get_range_extents libatk-1.0.so.0 -
:139f37cd4167d55d0b2b21053d3733e8dcdb8392 0x1bbd0 - libatk-bridge.so -
:139f37cd4167d55d0b2b21053d3733e8dcdb8392 0xfd2b - libatk-bridge.so -
:5b5557b5b0427930b220a00961393e29809c42f0 0x1effe - libdbus-1.so.3 -
:5b5557b5b0427930b220a00961393e29809c42f0 0xed55 dbus_connection_dispatch libdbus-1.so.3 -
:bb21322626c08eadcaed3b7d58d261951193b7d7 0x884e - libatspi.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x46feb g_main_context_dispatch libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x47390 - libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x47472 g_main_context_iteration libglib-2.0.so.0 -
:d0b2ee750bf29544a82c25b03f3fe22086c6c4be 0x98c04 g_application_run libgio-2.0.so.0 -
:825a25d0adfb6ec9f9b227d92305a6d22cf10c59 0x1f899 - [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/chrys/keyring-F7azXl
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:
:MAIL=/var/spool/mail/chrys
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/chrys/bin
:DESKTOP_SESSION=gnome
:
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=905
:LANG=de_DE.utf8
:GDM_LANG=de_DE.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:
:SHLVL=1
:LOGNAME=chrys
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-escTC5Fl2T,guid=28b91c1ae1259b29ac484ff00000008e
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/chrys
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-chrys-bR4emn/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/909,unix/unix:/tmp/.ICE-unix/909
:GPG_AGENT_INFO=/run/user/chrys/keyring-F7azXl/gpg:0:1
:SSH_AUTH_SOCK=/run/user/chrys/keyring-F7azXl/ssh
:DESKTOP_AUTOSTART_ID=10ad7e43ef17e3353a133875656819117700000009090014

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 32159                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       32159                32159                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/chrys/.xsession-errors
:pos:	4251
:flags:	02002
:2:/home/chrys/.xsession-errors
:pos:	4251
:flags:	02002
:3:socket:[20923]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[20924]
:pos:	0
:flags:	02004002
:6:socket:[22709]
:pos:	0
:flags:	02004002
:7:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:8:socket:[22710]
:pos:	0
:flags:	02004002
:9:socket:[20925]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:socket:[21084]
:pos:	0
:flags:	02
:12:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:13:socket:[21034]
:pos:	0
:flags:	02004002
:14:anon_inode:inotify
:pos:	0
:flags:	02004000
:15:/proc/1158/mounts
:pos:	0
:flags:	0100000
:16:socket:[22924]
:pos:	0
:flags:	02004002
:17:socket:[22950]
:pos:	0
:flags:	02
:18:socket:[22952]
:pos:	0
:flags:	02004002
:19:socket:[23217]
:pos:	0
:flags:	02004002
:20:socket:[21082]
:pos:	0
:flags:	02
:21:socket:[21083]
:pos:	0
:flags:	02004002
:22:socket:[21085]
:pos:	0
:flags:	02004002
:23:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:24:socket:[46024]
:pos:	0
:flags:	02
:25:socket:[46025]
:pos:	0
:flags:	02004002
:26:/home/chrys/.local/share/gvfs-metadata/computer:
:pos:	0
:flags:	0100000
:27:/home/chrys/.local/share/gvfs-metadata/computer:-a9c7ed66.log
:pos:	0
:flags:	0100000
:28:socket:[47069]
:pos:	0
:flags:	02
:29:socket:[47070]
:pos:	0
:flags:	02004002
:30:/home/chrys/.local/share/gvfs-metadata/root
:pos:	0
:flags:	0100000
:31:/home/chrys/.local/share/gvfs-metadata/root-949ed228.log
:pos:	0
:flags:	0100000

var_log_messages:
:Jun  3 21:19:03 chrys yum[8340]: Updated: 1:totem-nautilus-3.4.2-1.fc17.i686
:Jun  3 21:19:22 chrys yum[8340]: Updated: file-roller-nautilus-3.4.2-1.fc17.i686
:Jun  3 22:29:50 chrys kernel: [10123.126353] nautilus[1190]: segfault at 8 ip 46759739 sp bff2e760 error 4 in libgobject-2.0.so.0.3200.1 (deleted)[46748000+4c000]
:Jun  3 22:29:51 chrys abrt[10853]: Saved core dump of pid 1190 (/usr/bin/nautilus) to /var/spool/abrt/ccpp-2012-06-03-22:29:50-1190 (64831488 bytes)
:Jun  3 22:54:21 chrys kernel: [  437.300497] nautilus[1158]: segfault at 0 ip b7507e20 sp bff8d3a0 error 4 in libglib-2.0.so.0.3200.3[b7495000+126000]
:Jun  3 22:54:21 chrys abrt[1723]: Saved core dump of pid 1158 (/usr/bin/nautilus) to /var/spool/abrt/ccpp-2012-06-03-22:54:21-1158 (61575168 bytes)
Comment 1 chrys87 2012-06-03 17:03:08 EDT
Created attachment 588925 [details]
File: backtrace
Comment 2 chrys87 2012-06-03 17:03:10 EDT
Created attachment 588926 [details]
File: maps
Comment 3 chrys87 2012-06-03 17:03:13 EDT
Created attachment 588927 [details]
File: dso_list
Comment 4 chrys87 2012-06-03 17:03:15 EDT
Created attachment 588928 [details]
File: build_ids
Comment 5 Cosimo Cecchi 2012-06-06 09:26:05 EDT
Looks like a crash in GTK accessibility code. I forwarded this upstream here [1] with a patch.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=677551

Note You need to log in before you can comment on or make changes to this bug.