Bug 82796 - Phoebe-2, Installer & disk druid don't recognize hard drives in VIA vt82c686a (rev 22) IDE UDMA66 controller
Phoebe-2, Installer & disk druid don't recognize hard drives in VIA vt82c686a...
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
phoebe
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-01-26 12:38 EST by Roberto Bertolusso
Modified: 2007-03-27 00:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-29 12:31:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roberto Bertolusso 2003-01-26 12:38:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
Installer doesn't recognize I have a RH8 installation in /dev/hde6 so it offers
no chance to upgrade.
If I continue with a new installation, when selected manual partition, disk
druid (maybe the installer) shows an error message in a dialog stating it cannot
find any hard disk (I have 2, one in /dev/hde and the other in /dev/hdg, a CDROM
in dev/hda and a ide zip drive in /dev/hdb) and reboots giving no other option.

I had no problems installing in same hardware RH8 and previous 2 betas.

I think the chip is a Fastrack 133, and this is a snippet of dmesg when booting
in RH8

VP_IDE: VIA vt82c686a (rev 22) IDE UDMA66 controller on pci00:07.1
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
PDC20265: IDE controller on PCI bus 00 dev 80
PCI: Found IRQ 10 for device 00:10.0
PCI: Sharing IRQ 10 with 00:07.3
PCI: Sharing IRQ 10 with 00:07.2
PDC20265: chipset revision 2
PDC20265: not 100% native mode: will probe irqs later
PDC20265: ROM enabled at 0xdffd0000
PDC20265: (U)DMA Burst Bit ENABLED Primary PCI Mode Secondary PCI Mode.
    ide2: BM-DMA at 0xc800-0xc807, BIOS settings: hde:DMA, hdf:pio
    ide3: BM-DMA at 0xc808-0xc80f, BIOS settings: hdg:DMA, hdh:pio
hda: Pioneer DVD-ROM ATAPIModel DVD-105S 012, ATAPI CD/DVD-ROM drive
hdb: IOMEGA ZIP 100 ATAPI, ATAPI FLOPPY drive
hde: ST320414A, ATA DISK drive
hdg: ST320414A, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide2 at 0xd800-0xd807,0xd402 on irq 10
ide3 at 0xd000-0xd007,0xcc02 on irq 10
blk: queue c03ba6ec, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c03ba6ec, I/O limit 4095Mb (mask 0xffffffff)
hde: 39102336 sectors (20020 MB) w/2048KiB Cache, CHS=38792/16/63, UDMA(100)
blk: queue c03baa30, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c03baa30, I/O limit 4095Mb (mask 0xffffffff)
hdg: 39102336 sectors (20020 MB) w/2048KiB Cache, CHS=38792/16/63, UDMA(100)
ide-floppy driver 0.99.newide
hdb: No disk in drive
hdb: 98304kB, 96/64/32 CHS, 4096 kBps, 512 sector size, 2941 rpm
Partition check:
 hde: [PTBL] [2434/255/63] hde1 hde2 hde3 < hde5 hde6 hde7 hde8 hde9 >
 hdg: [PTBL] [2434/255/63] hdg1 hdg2 hdg3 < hdg5 hdg6 hdg7 >


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Follow installation until you can choose manual or automatic partition
2.Select manual partition
3.
    

Actual Results:  Error message saying the installer couldn't find any disk to
install. 

Expected Results:  Open disk druid with info about hard disks

Additional info:
Comment 2 Jeremy Katz 2003-01-27 17:48:10 EST
Can you try downloading the update disk image from
http://people.redhat.com/~katzj/phoebe-pdcdetect.img and see if it works using
it?  (Information on using update disks is available from
http://rhlinux.redhat.com/anaconda/updatedisks.html)
Comment 3 Roberto Bertolusso 2003-01-29 10:48:25 EST
Yes. The problem was resolved using the disk image. It is installing
right now. 
Thank you
Roberto
Comment 4 Jeremy Katz 2003-01-29 12:31:35 EST
This fix is in our current source base, closing accordingly

Note You need to log in before you can comment on or make changes to this bug.