Bug 828 - rxvt is not properly localized
rxvt is not properly localized
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rxvt (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-14 03:42 EST by Aleksey Nogin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-24 12:22:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 1999-01-14 03:42:28 EST
When I start rxvt and switch keyboard into the Cyrillic mode
(I am using Xkb, it generate Cyrillic_* keysyms) and start
typing, rxvt would not react (as if nothing is typed).

When xterm, Netscape or gvim is started from the same shell,
cyrillics works fine.

I had the same problem in RedHat 5.1

In RH 5.2 I checked it with the following setup:

glibc-2.0.7-29
rxvt-2.4.7-2
XFree86-libs-3.3.2.3-25
XFree86-3.3.3-1
XFree86-SVGA-3.3.3-1

P.S. nxterm has the same problem (I am going to report it as
a separate bug) and as a result, I can only use xterm.
Comment 1 Aleksey Nogin 1999-01-25 21:35:59 EST
The problem still exists when using XFree*3.3.3.1-1
Comment 2 Aleksey Nogin 1999-03-22 17:07:59 EST
When I rebuilt rxvt-2.6.PRE2-1.src.rpm (from RawHide) on an RedHat-5.2
system (with all updates, including XFree86*-3.3.3.1-1), I did not
have any locale problems.

I can not test rxvt-2.6.PRE2-1.i386.rpm from RawHide since I do not
have access to glibc-2.1 machine

Note You need to log in before you can comment on or make changes to this bug.