Bug 82801 - Gnome fails to report quota excess to user in a timely manner
Gnome fails to report quota excess to user in a timely manner
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
8.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-26 14:16 EST by Scott R. Godin
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:52:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stuff from /var/log/messages detailing extent of problem (268.07 KB, text/plain)
2003-01-26 14:19 EST, Scott R. Godin
no flags Details

  None (edit)
Description Scott R. Godin 2003-01-26 14:16:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
set up a few users on the system and applied a 40MB quota to each user. 

each user has access to X, and Mozilla via the new Gnome/KDE setup. Most users
are not *really* aware of how different linux is from windows :-) (nor should
they really NEED to be just to web-browse)

However, the default Cache limit for Moz, is 50MB. 

One user exceeded the 45MB Hard limit, and gnome panel promptly crashed..
reloading gnome-panel and trying to log-out subsequently only results in the
exit of gnome-panel. (unable to update authentication tokens due to quota excess
apparently)

It took me a bit to figure out what was the excess problem -- the user had
downloaded a few files, but none seemed excessive. A further du -h on his
account showed the size of the cache to be excessive, and clearing and and
setting it lower solved the problem.

HOWEVER, what I would have preferred to see was a dialog box popping up in Gnome
advising the user that they were out of disk space (similar to how the same is
reported under MacOS since forever) and that some files and caches would need to
be cleaned up in order to continue. 

This problem also had the side effect of filling /var/log/messages with hundreds
of repeat messages. *sigh* (attached for your perusal and amusement)



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.set user quotas to 40MB with a Hard limit of 45MB
2.browse lots of pages with Mozilla until quota exceeded
3.watch panel crash and /var/log/messages fill, with no actual dialog-box
notification to user that they are close to (much less already HAVE) exceeding
their limits
    

Actual Results:  see attached 

Expected Results:  dialog box warning user they are about to (or have) exceeded
their limits set by quota.

Additional info:
Comment 1 Scott R. Godin 2003-01-26 14:19:07 EST
Created attachment 89612 [details]
stuff from /var/log/messages detailing extent of problem

as you can see, the damage was going on for some time before the reason for the
problem was discovered. the user had no clue what was going on other than
suddenly the panel went away and nothing else was working properly.

user could not even log-out due to absence of log-out option in right-click
menu when you click on the desktop :P (<-- strongly recommended addition to
gnome!)
Comment 2 Scott R. Godin 2003-01-26 14:29:34 EST
as you can see, an inordinate amount of stuff was generated by gconfd to
/var/log/messages in a matter of seconds, from [22:54:06 - 22:54:36], and from
[23:03:03 - 23:07:44] (this last being the most extreme)

I find it hard to believe that no mechanism exists whereby the quota excess
might be reported to the end-user via a dialog-box.

also, user received no e-mail regarding the excess. This was not a user that was
familiar with using the Terminal/console and would not have thought to check
same for further information. 

I've since updated my MOTD to forewarn them, but yeesh, the SYSTEM should do
this. :)
Comment 3 Bill Nottingham 2006-08-07 13:50:41 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 4 Bill Nottingham 2006-10-18 10:52:58 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.