Bug 828011 - i3status makes odd characters in i3bar.
i3status makes odd characters in i3bar.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: i3status (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Preisler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 21:27 EDT by Wade Mealing
Modified: 2012-06-15 20:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 20:05:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2012-06-03 21:27:43 EDT
Description of problem:

i3status default configuration creates non-sane display on the i3bar.  I don't know if this is by choice or not, but it ends up looking odd on the standard i3bar.

Version-Release number of selected component (if applicable):

i3status-2.1.3.fc17

How reproducible:

Every time

Steps to Reproduce:
1. Install i3
2. Run and accept defaults.
3. Look at the i3bar (bottom bar)
  
Actual results:

dzen2 style "information" ^6fg(#333333) etc on the bar.

Expected results:

No dzen2 style text on the i3bar.

Additional info:

This can be modified by configuring a simple display in the ~/.i3status.conf but that doesn't solve this bug for everyone.

Could be a design choice, i'm unsure what to do about this.
Comment 1 Fedora Update System 2012-06-06 11:24:10 EDT
i3status-2.5.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/i3status-2.5.1-1.fc17
Comment 2 Martin Preisler 2012-06-06 11:30:00 EDT
Hi, I am updating all i3 related packages to newest versions.

I reproduced your issue on 2.1.3, seems to be fixed for me with 2.5.1 so please give it a go. Newest i3 itself and i3lock are also in testing.
Comment 3 Wade Mealing 2012-06-06 21:16:30 EDT
Used your source RPM on RHEL6.  Problem solved for EL6.  I imagine it will also work for Fedora 17.
Comment 4 Fedora Update System 2012-06-07 19:02:56 EDT
Package i3status-2.5.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing i3status-2.5.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9044/i3status-2.5.1-1.fc17
then log in and leave karma (feedback).
Comment 5 Wade Mealing 2012-06-11 20:05:29 EDT
Looks good for f17 too.
Comment 6 Fedora Update System 2012-06-15 20:05:57 EDT
i3status-2.5.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.