This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 82806 - Combo LAN/Modem card does not initialize reliably
Combo LAN/Modem card does not initialize reliably
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On: 86541
Blocks: 81720 85893 rcn-modem
  Show dependency treegraph
 
Reported: 2003-01-26 16:51 EST by Nick Mumbach
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 07:14:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
details of improperly initialized PC card behavior (2.66 KB, text/plain)
2003-01-26 16:54 EST, Nick Mumbach
no flags Details

  None (edit)
Description Nick Mumbach 2003-01-26 16:51:43 EST
Description of problem: Unreliable LAN/Modem PCcard initialization


Version-Release number of selected component (if applicable):


How reproducible: frequent


Steps to Reproduce:
1.see attached
2.
3.
    
Actual results: see attached


Expected results: see attached
Additional info: see attached
Comment 1 Nick Mumbach 2003-01-26 16:54:15 EST
Created attachment 89613 [details]
details of improperly initialized PC card behavior
Comment 2 Brent Fox 2003-01-30 10:31:24 EST
Here are the contents of the attachment:

I am running an installation of Red Hat Linux 8.0 on a Dell Latitude CPT Laptop
with an Intel Celeron 466
processor, 192Mb RAM, a 12Gb Hard Drive, and a Dell/3Com 3CCFEM656 combo PCMCIA
card providing 10/100 LAN and
56K modem capabilities.  I use a Red Hat Network entitlement to keep my system
up-to-date.

I had originally (RHL 7.3?) reported a problem wherein the Linux boot process
reported the following error:
'Bringing up interface eth0: 3c59x device does not seem to be present, delaying
eth0 initialization.'
I was subsequently informed that the interface SHOULD start when the PCMCIA
services were later started,
and that seemed to be the case, (when the 'Cyclone' driver came up) so I dropped
the issue.

Aside from the inadvisability of displaying error messages when there are, in
fact, no errors, (due to the
reality that people will grow used to seeing and ignoring said messages,
pre-disposing them to ignore other,
more imporatant messages) it seems I must revisit the problems with the PC card
initialization.  The card does
not initialize reliably.  The boot log shows apparently the same sequence of
events, as descibed above, but
sometimes the LAN is accessible, and sometimes it is not.  When I am connected
to a 10-baseT hub, the 10mb
indicator on the PC card dongle is on, as is the indicator on the hub, but
sometimes I have netowrk access and
sometimes not. On a 10/100 hub and network, if the network connection is good,
the dongle 100mb indicator is
on solid; if not, it flashes; I could not check the indicator on the hub, as it
is not accessible to me.

Very infrequently, I can restore network connectivity by unplugging the PC card
after start up, and plugging
it back in a few moments later.  It appears in ALL cases, on both 10BT and
100BTX network connections, that if
I boot to RH Linux 8.0 without the card in place, and then insert the card, the
LAN connection is OK.

Under NO circumstances am I able to use the Internet Connection Wizard to
establish a modem interface using
the PC card; it reports "no modems found."  Yet, the Hardware Browser reports
the 3CCFEM656 10/100 LAN+56K
Modem Cardbus device, with Driver 3c59x, Device N/A, under "Modems" when the
card is installed.

While I am as loathe to report it as you are to hear it, the card works properly
when I boot to W95 or W98,
both when installed prior to power-up and after the fact, LAN and Modem, so the
hardware would seem to be
functional.

I don't know if this WAS a problem when I first reported in in 7.3(2? limbo?
null?), or if it was as 
intermittent as it seems to be in 8.0 and I did not recognize the fact.  I am
inexpert in these matters, as I
am trying to learn Linux from scratch with no prior Unix experience.
Comment 3 Brent Fox 2003-01-30 10:54:09 EST
I think that there are several problems here, but the biggest seems to be the
fact that the Internet Connection Wizard does not find any modems on the system.
 I am going to change the component of this bug report to redhat-config-network,
which the Internet Connection Wizard is a part of.

hwbrowser is basically a frontend to our hardware detection library, called
kudzu.  kudzu sometimes refers to Ethernet/modem combo cards as "Network"
devices instead of "Modem" devices.  Since redhat-config-network probes for all
"modem class" devices, perhaps the bug is really in kudzu if it thinks that this
device isn't a "modem class".  I don't know enough about the details of network
devices to guess any more than that.

Comment 4 Harald Hoyer 2003-01-30 11:08:10 EST
kudzu should report Modems, if I search for them
Comment 5 Nick Mumbach 2003-02-18 19:08:48 EST
The card shows up both under Network Devices and Modems, in the hardware
browser. Network devices shows a Selected Device of 3CCFE656 Cyclone Cardbus,
with all device information filled in, including Device: /dev/eth.  Modems shows
a Selected Device of 3CCFEM656 10/100 LAN+56K Modem Cardus, and the device
information down below is filled in with the exception of Device:, which instead
says N/A.
Comment 6 Bill Nottingham 2003-02-18 19:16:18 EST
What does 'kudzu -p -c modem' say?
Comment 7 Nick Mumbach 2003-02-24 16:48:42 EST
kudzu -p -c reports as follows:
[root@Nick-Dell-RH root]# kudzu -p -c modem
-
class: MODEM
bus: PCI
detached: 1
driver: 3C59X
desc: "3Com Corporation|3CCFEM656 10/100 LAN+56K Modem Cardbus"
vendorId: 10b7
deviceId: 6561
subVendorId: 10b7
subDeviceId: 656b
pciType: 2
(end of kudzu output)

Comment 8 Bill Nottingham 2003-02-24 16:53:17 EST
Ok, it appears to be probing ok. Assigning back to redhat-config-network.
Comment 9 Harald Hoyer 2005-09-20 08:31:05 EDT
hmm, no device node output from kudzu here.
Comment 10 Harald Hoyer 2007-11-13 07:14:49 EST
will have to wait for HAL support in s-c-network

Note You need to log in before you can comment on or make changes to this bug.