Bug 82808 - olddir directive broken (or changed?)
olddir directive broken (or changed?)
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: logrotate (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-26 22:11 EST by James Ralston
Modified: 2015-01-07 19:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-18 00:29:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Ralston 2003-01-26 22:11:10 EST
Description of problem:

The "olddir" directive appears to be broken.  Specifically, the olddir option
now seems to be interpreted relative to the directory which contains the logfile
being processed.  (The previous behavior was that olddir specified an absolute
directory.)

If this is an intentional change, then please update the documentation (i.e.,
the man page) to reflect the change.

Version-Release number of selected component (if applicable):

logwatch-4.3.1-1

How reproducible:

Replace the contents of /etc/logrotate.d/rpm with this:

    /var/log/rpmpkgs {
        daily
        notifempty
        missingok
        rotate 7
        olddir /var/log/OLD
        nocompress
        sharedscripts
    }

Then run:

    /usr/sbin/logrotate --debug=100 /etc/logrotate.conf

Actual results:

error: rpm:9 error verifying olddir path /var/log//var/log/OLD: No such file or
directory

Expected results:

Logrotate puts the rotated log files in /var/log/OLD.
Comment 1 Elliot Lee 2003-01-29 09:52:27 EST
What logrotate version are you running (logrotate, not logwatch)?
Comment 2 James Ralston 2003-01-31 02:30:48 EST
Argh... I apologize for my inability to differentiate LOGWATCH from LOGROTATE. 
(This isn't the first time...)

$ rpm -qa | grep -i ^log | sort
logrotate-3.6.6-1
logwatch-4.3.1-1
Comment 3 James Ralston 2003-02-18 00:29:22 EST
I grabbed logrotate-3.6.8-1 from Rawhide, and this bug is fixed; the olddir
directive is correctly interpreted as an absolute path (the same as previous
versions).  Danke; I'm closing this report.

Note You need to log in before you can comment on or make changes to this bug.