Bug 828087 - Unnecessary or even wrong dependencies of opencv
Unnecessary or even wrong dependencies of opencv
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: opencv (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 04:38 EDT by Honza Horak
Modified: 2012-06-04 18:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 18:10:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed changes in opencv.spec (1.12 KB, patch)
2012-06-04 04:43 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description Honza Horak 2012-06-04 04:38:56 EDT
Description of problem:

It seems opencv contains some BuildRequires, that are not needed. These bring unnecessary dependencies, which we should generally avoid if possible.

For example I haven't found a reason why imlib2, f2c and libucil should be in BuildRequires.

Other three prerequisites (eigen2, openni and openni-primesense) are optional, what about making them optional even in build? Users could build with them using "--with" options (--with=eigen2, --with=eigen3, --with=openni).

If I miss some point why some of these are really needed in default build, give me some explanation, please.
Comment 1 Honza Horak 2012-06-04 04:43:03 EDT
Created attachment 589072 [details]
proposed changes in opencv.spec
Comment 2 Nicolas Chauvet (kwizart) 2012-06-04 05:35:36 EDT
I will have a look tonight, but opencv have been made modular, so it's possible to solve things by spliting the package instead (which can be built using --with rpm conditionals also).
This might be better handled with 2.4.x version (to be updated in Rawhide only because ABI changes).
Comment 3 Nicolas Chauvet (kwizart) 2012-06-04 18:10:16 EDT
Patch committed on master.
Thx

Note You need to log in before you can comment on or make changes to this bug.