Bug 828089 - [RFE] Webadmin: there is no search/filter for template or vm disks under the disks tab
Summary: [RFE] Webadmin: there is no search/filter for template or vm disks under the ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: ---
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: ---
Assignee: Allon Mureinik
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-04 08:39 UTC by Dafna Ron
Modified: 2017-11-26 11:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-26 11:59:17 UTC
oVirt Team: Storage
ylavi: ovirt-future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Dafna Ron 2012-06-04 08:39:59 UTC
Description of problem:

all disks, templates and vm's disks are located under the disks tab and the only reason to know if the disk is a template or a vm disk is by selecting the disk and looking at the button option (the move button will be grayed out for template dsks and the copy button will be grayed out for vm's disks).
also, we cannot search for disks by template/vm type.

since I know the difference between the copy/move commands I was able to figure it out but I think that to the users it will seem odd. 

please also consider these examples:
* I want to move mass number of disks from one domain to other
* I want to copy templates disks to a new domain I added without doing it one by one.

please add a search option and column to the disk type (template/vm type) so that we can multi select and filter the disks.


Version-Release number of selected component (if applicable):

si4

How reproducible:

100%

Steps to Reproduce:
1. create vms and templates
2. go to the disks tab
3.
 
Actual results:

* there is no visual way to distinguish between the vm's and templates disks without selecting one
* there is no search option for vm/template disk type

Expected results:

we should allow mass move/copy and help the user to distinguish between the disk types

Additional info:

Comment 3 Allon Mureinik 2013-06-25 13:36:08 UTC
> * there is no visual way to distinguish between the vm's and templates disks
> without selecting one
In 3.2 they have different icons (5th column in the main tab). Reducing severity based on this.

> * there is no search option for vm/template disk type
agreed.

Comment 6 Yaniv Lavi 2017-11-26 11:59:17 UTC
No customer request and open since 2012.
Closing and we can reopen when we get a user/customer request for this.


Note You need to log in before you can comment on or make changes to this bug.