Bug 828096 - Please provide better disk size in output of "targetcli ls /"
Summary: Please provide better disk size in output of "targetcli ls /"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-target-utils
Version: 6.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Gris Ge
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-04 08:49 UTC by Gris Ge
Modified: 2013-02-21 10:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:48:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0457 normal SHIPPED_LIVE fcoe-target-utils bug fix and enhancement update 2013-02-20 21:07:34 UTC

Description Gris Ge 2012-06-04 08:49:56 UTC
Description of problem:
Currently (RHEL 6.3 fcoe-target) show LUN size like this:
===
[/tmp/fcoe-lun1 (10.0G) activated]
===

Please consider to provide info like this:
====
[/tmp/fcoe-lun1 10737418240B (10.0GiB) activated]
#               ^^^^^^^^^^^^ ^^^^^^^
====

A single "G" was treat as 10^9 not 2^30.

Version-Release number of selected component (if applicable):
fcoe-target-utils-2.0rc1.fb10-5.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. targetcli ls /
2.
3.
  
Actual results:


Expected results:


Additional info:

Request exception. QE just want fcoe-target-utils to follow IEC standard.
http://physics.nist.gov/cuu/Units/binary.html

Comment 1 Andy Grover 2012-06-05 23:54:49 UTC
Instead of listing GiB, would it be preferable to switch to power-of-10 for everything?

Comment 2 Gris Ge 2012-07-17 01:17:29 UTC
Many software are using GiB now, so please make GiB (2^30) as default and make GB (10^9) as option.

Comment 4 Gris Ge 2013-01-25 03:24:00 UTC
fcoe-target-utils-2.0rc1.fb16-3.el6.noarch now using KiB, MiB, GiB, TiB.

VERIFY.

Even though, it does not support using KiB format to create LUN: Bug #903909

Comment 6 errata-xmlrpc 2013-02-21 10:48:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0457.html


Note You need to log in before you can comment on or make changes to this bug.