Bug 82810 - file segfaults after examining an Ogg Vorbis file
Summary: file segfaults after examining an Ogg Vorbis file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: file   
(Show other bugs)
Version: phoebe
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-27 04:23 UTC by James Ralston
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-27 18:38:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Ralston 2003-01-27 04:23:44 UTC
Description of problem:

The "file" command will die with SIGSEGV if it is passed multiple files to
examine, and any file except the last file is an Ogg Vorbis file.

Version-Release number of selected component (if applicable):

file-3.39-4

How reproducible:

Invoke file like this:

    file some-file.ogg some-other-file

Actual results:

Segmentation fault.

Expected results:

Success.

Additional info:

The act of examining an Ogg Vorbis file seems to be what triggers this bug.

Comment 1 James Ralston 2003-01-27 04:25:37 UTC
A clarification: file *does* print information about the Ogg Vorbis file
successfully; it only dies when it attempts to examine the next file in the argv
list.


Comment 2 Jeff Johnson 2003-01-27 14:13:19 UTC
Yup, this problem bit rpm too, which has an internal copy
of file-3.39. Fix there was to remove new-fangled
/usr/share/magic tests.

Do
   diff -u /usr/share/magic /usr/lib/rpm/magic
for details.

Comment 3 Jeff Johnson 2003-01-27 18:38:05 UTC
Fixed (as described) in file-3.39-6.

Comment 4 James Ralston 2003-01-28 01:52:57 UTC
Hurm.  While file doesn't crash when using /usr/lib/rpm/magic, I think it's
bogus that a magic(5) file (one that doesn't even appear to be deliberately
mangled, even) can cause file to segfault.  File should not segfault, regardless
of what magic it's using.

What do the upstream maintainers think about this?


Comment 5 Jeff Johnson 2003-01-28 12:07:38 UTC
There's a bug in the magic file distributed with
file-3.39.

Go ask the upstream maintainers if you wish. The expedient
fix is
    Don't do that.


Note You need to log in before you can comment on or make changes to this bug.