Bug 82811 - codeweavers-wine-20020904-7.i386.rpm unable to locate KDE, GNOME
codeweavers-wine-20020904-7.i386.rpm unable to locate KDE, GNOME
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: wine (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
http://www.codeweavers.com/technology...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-26 23:44 EST by David White
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-27 09:02:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David White 2003-01-26 23:44:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
Downloaded latest wine from above URL and installed. Installer bitches about not
being able to integrate with the Phoebe desktop: 

[root@localhost david]# rpm -i codeweavers-wine-20020904-7.i386.rpm
Warning: Unable to locate KDE. KDE integration not done
Manually copy from /opt/wine/kde for later installation.
*Warning* Unable to locate GNOME. GNOME integration not done
Manually copy from /opt/wine/gnome for later installation.
Creating symbolic links in /usr/bin for wine, winesetup, and winemaker

Attempting to run wine as normal user fails, with the following message:

[david@localhost david]$ wine notepad.exe
Invoking /opt/wine/bin/wine.bin notepad.exe ...
wine: chdir to /tmp/.wine-david/server-307-145e58 : No such file or directory
Wine failed with return code 1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download and install CodeWeavers rpm as root
2. run winesetup as normal user.  I configured for Win-98
3. try wine notepad.exe
    

Actual Results:  Error dialog with message above

Expected Results:  MS-DOS emulation

Additional info:

I picked most of the selectable packages during installation, though not the
**EVERYTHING** package.  Did I miss something?  Does RedHat have a version
tailored to its desktop modifications?  Can you give CodeWeavers a clue what's
got to change to work with your distribution?  And I'm not sure what to make of
the startup failure in user mode...
Comment 1 Need Real Name 2003-01-28 12:03:08 EST
I think this is an incompatibility between wine and Phoebe. I see the same
behavior with our internal version of Lotus Notes i.e. the server directory
message in the log file and wine exiting with an error. This package works just
fine on Psyche...

Does wine have any dependencies on LinuxThreads or side effect behaviors that
may be different in NPTL?
Comment 2 Need Real Name 2003-01-28 12:27:41 EST
Found a discussion on winehq wine-devel ML - appears to be threading breakage.
http://www.winehq.com/hypermail/wine-devel/2003/01/0977.html
Comment 3 Need Real Name 2003-01-31 17:00:03 EST
Added LD_ASSUME_KERNEL=2.2.5 to environment and most wine apps seem to be working...
Comment 4 Vedat Ozdemirler 2003-03-23 11:26:59 EST
I have tried the wine-20030318-1rh8winehq version of wine with same error condition.
Comment 5 Karsten Hopp 2004-01-27 09:02:48 EST
Red Hat Linux 9 didn't include wine, codeweavers wine or any other wine
packages are not supported by Red Hat. Please report bugs to the
maintainers of those packages.

Note You need to log in before you can comment on or make changes to this bug.