Bug 828130 - Pandoc fails due to libffi dependency error
Pandoc fails due to libffi dependency error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pandoc (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 06:26 EDT by Chris Cowley
Modified: 2012-06-10 23:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-10 23:34:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Cowley 2012-06-04 06:26:38 EDT
Description of problem:
Any attempt to run results in an error due to a missing libffi libary.

Version-Release number of selected component (if applicable):
1.8.2.1-8.

How reproducible:
Everytime

Steps to Reproduce:
1. Using Github default README.md run "pandoc README.md -o README.html"
2.
3.
  
Actual results:
pandoc: error while loading shared libraries: libffi.so.6: cannot open shared object file: No such file or directory

Expected results:
Produce html file

Additional info:
yum provides */libffi.so.6 confirms the lib does not exist in repos.

chris@paul:~ $ ls -l /usr/lib64/libffi*
lrwxrwxrwx. 1 root root    16 May 31 21:39 /usr/lib64/libffi.so -> libffi.so.5.0.10
lrwxrwxrwx. 1 root root    16 Jul  5  2008 /usr/lib64/libffi.so.5 -> libffi.so.5.0.10
-rwxr-xr-x. 1 root root 33464 Jan 14 07:10 /usr/lib64/libffi.so.5.0.10
Comment 1 Jens Petersen 2012-06-05 06:44:26 EDT
Hmm that looks pretty strange.

$ rpm -q pandoc
pandoc-1.8.2.1-8.fc17.x86_64
$ rpm -q --requires pandoc | grep libffi
libffi.so.5()(64bit)  
$ rpm -q libffi.x86_64
libffi-3.0.10-2.fc17.x86_64
[petersen@localhost ~/tmp]$ rpm -ql libffi.x86_64
/usr/lib64/libffi.so.5
/usr/lib64/libffi.so.5.0.10
/usr/share/doc/libffi-3.0.10
/usr/share/doc/libffi-3.0.10/LICENSE
/usr/share/doc/libffi-3.0.10/README

http://koji.fedoraproject.org/koji/rpminfo?rpmID=2941298

Even rawhide is still on libffi.so.5.

Perhaps you have libffi6 installed locally and earlier built pandoc yourself??
Comment 2 Chris Cowley 2012-06-05 07:13:30 EDT
Nope this was a clean install the other day, I have not got any self-built packages on it. I do not have libffi6 installed either, nor is it available to me in the repositories. The only 3rd party repos I have enabled are RPMFusion, from which I have installed a couple of video related bits. I do not see how that can be related - hell I haven't even installed the akmod-nvidia this time (congratulations Nouveau guys, the performance is finally really good).

chris@paul:~$ rpm -qa | grep libffi
libffi-3.0.10-2.fc17.x86_64
libffi-devel-3.0.10-2.fc17.x86_64

I do not do anything clever with this PC, it is the family one. My rpm queries match yours as well:

chris@paul:~$ rpm -q pandoc
pandoc-1.8.2.1-8.fc17.x86_64

chris@paul:~$ rpm -q --requires pandoc | grep libffi
libffi.so.5()(64bit)

chris@paul:~$ rpm -ql libffi.x86_64
/usr/lib64/libffi.so.5
/usr/lib64/libffi.so.5.0.10
/usr/share/doc/libffi-3.0.10
/usr/share/doc/libffi-3.0.10/LICENSE
/usr/share/doc/libffi-3.0.10/README

I am very surprised that you would close this as not a bug - looks like a bug to me, and if I closed an issue with no resolution in my day job my colleagues would not be happy.
Comment 3 Chris Cowley 2012-06-05 07:15:23 EDT
When I get a chance I will spin a uber-clean VM and see what I get.
Comment 4 Jens Petersen 2012-06-05 21:17:26 EDT
Sure, thanks - please reopen if you can still reproduce the problem in a clean environment.
Comment 5 Jens Petersen 2012-06-05 21:23:01 EDT
(In reply to comment #2)
> I am very surprised that you would close this as not a bug - looks like a
> bug to me, and if I closed an issue with no resolution in my day job my
> colleagues would not be happy.

I can reopen if you like but that doesn't really change anything :)
- there was not a single mention of libffi.so.6 in your follow-up comment.

What do:

$ which pandoc

and

$ ldd `which pandoc` | grep libffi

say?
Comment 6 Jens Petersen 2012-06-08 05:59:04 EDT
I see Ubuntu 12.04 has libffi.so.6...

Note You need to log in before you can comment on or make changes to this bug.