Bug 82814 - evolution crashes if windows closed in odd order
evolution crashes if windows closed in odd order
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-27 01:15 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-02 01:06:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-01-27 01:15:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
evolution crashes if dialog boxes are closed in wrong order, e.g. if parent
dialog box is closed before child.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run evolution
2. select tools .. mail settings ..accounts .. (select account) .. 
3. edit account
4. select "special folders" in Account Editor dialog box
5. click DRAFTS
6. while folder select dlgbox is open, close Account Editor
7. close folder selector
8. evolution crashes with :

Gdk-ERROR **: BadWindow (invalid Window parameter)
  serial 15771 error_code 3 request_code 19 minor_code 0




Actual Results:  crash

Expected Results:  either stop user from closing dialog boxes in wrong order or
not crash if they do.

Additional info:

Incidentally, while trying to reproduce this, it would appear that 
once this happens once, evolution is flakey afterwards. Second time around, the
folder selector dialog box wouldn't appear and evolution takes forever (> 1 min
) to close down, i lose interest and start manually killing processes.
Comment 1 Jeremy Katz 2003-02-02 01:06:51 EST
This seems to be fixed in the newer release in rawhide.

Note You need to log in before you can comment on or make changes to this bug.