Bug 828169 - [RFE:EPEL] Request to add gdb-heap to EPEL
[RFE:EPEL] Request to add gdb-heap to EPEL
Status: ON_QA
Product: Fedora
Classification: Fedora
Component: gdb-heap (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 967086
  Show dependency treegraph
 
Reported: 2012-06-04 08:01 EDT by Travis Gummels
Modified: 2013-06-27 19:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: gdb-heap-0.5-9.1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Dave Malcolm 2012-08-17 16:57:56 EDT
I've requested an EPEL 6 branch of gdb-heap here:
  https://bugzilla.redhat.com/show_bug.cgi?id=618451#c25

(following the process in http://fedoraproject.org/wiki/Getting_a_Fedora_package_in_EPEL )
Comment 2 Fedora Update System 2012-08-22 13:35:29 EDT
gdb-heap-0.5-9.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/gdb-heap-0.5-9.el6
Comment 3 Fedora Update System 2012-08-23 13:02:16 EDT
gdb-heap-0.5-9.el6 has been pushed to the Fedora EPEL 6 testing repository.
Comment 4 Jacob Hunt 2012-10-29 16:19:03 EDT
I tried to test the gdb-heap package

yum install --enablerepo=epel-testing gdb-heap

....

Error: Package: gdb-heap-0.5-9.el6.x86_64 (epel-testing)
           Requires: glibc(x86-64) = 2.15
           Installed: glibc-2.12-1.80.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201206132210.x86_64/6.3)
               glibc(x86-64) = 2.12-1.80.el6

It requires glibc-2.15, but the latest glibc as of RHEL 6.3 is glibc-2.12-1.80.el6.x86_64

In the spec file the global version is define

%global glibc_version 2.15

Can we have another build that will be able to use the version in RHEL6?

Thanks,
Jacob
Comment 6 Dave Malcolm 2013-01-31 06:42:30 EST
Candidate fix committed to pkgs git:
http://pkgs.fedoraproject.org/cgit/gdb-heap.git/commit/?h=el6&id=057ef531de0ce4073ee1a0015113cfdaea9259d3

Tested locally; build underway as:
  Building gdb-heap-0.5-9.1.el6 for el6-candidate
  Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4917216
Comment 7 Dave Malcolm 2013-01-31 06:57:11 EST
I've updated the update (so to speak) to 0.5-9.1:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6797/gdb-heap-0.5-9.1.el6
Comment 8 Fedora Update System 2013-02-01 08:14:42 EST
gdb-heap-0.5-9.1.el6 has been pushed to the Fedora EPEL 6 testing repository.

Note You need to log in before you can comment on or make changes to this bug.