Bug 82817 - ksymoops RPM does not list all dependencies
ksymoops RPM does not list all dependencies
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: ksymoops (Show other bugs)
phoebe
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-27 02:12 EST by James Ralston
Modified: 2013-07-02 22:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-28 00:40:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Ralston 2003-01-27 02:12:13 EST
ksymoops RPM does not list all dependencies

The ksymoops program has dependencies that aren't specified in its RPM package.

At the minimum, its spec file needs this:

    Requires: binutils

I *think* depending on binutils will pull in everything that ksymoops needs, but
I'm not certain.

I encountered this packaging bug because I needed to install ksymoops on a
server which had been installed with the "Minimal Install" option, and it
quickly became apparent that ksymoops had dependencies not indicated by its RPM
package.

Note that the ksymoops in released versions of Red Hat Linux (e.g., Psyche) also
have this packaging bug.
Comment 1 Bill Nottingham 2003-01-28 00:40:52 EST
ksymoops isn't actually needed with current kernels; it's since been removed
from the tree.
Comment 2 James Ralston 2003-01-28 01:57:02 EST
Snazzy.

Based on its input and output, I'm guessing that ksymoops is still needed for
RHL <=8.0?

Note You need to log in before you can comment on or make changes to this bug.