Bug 828172 - [abrt] pan-0.137-1.fc17: _gnutls_x509_crt_get_raw_dn2: Process /usr/bin/pan was killed by signal 11 (SIGSEGV)
[abrt] pan-0.137-1.fc17: _gnutls_x509_crt_get_raw_dn2: Process /usr/bin/pan w...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: pan (Show other bugs)
17
x86_64 All
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Kovar
Fedora Extras Quality Assurance
abrt_hash:b68cdf66dcdc89d2ba0a5939728...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 08:10 EDT by Stefan Jensen
Modified: 2012-06-05 09:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 09:45:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (7.75 KB, text/plain)
2012-06-04 08:10 EDT, Stefan Jensen
no flags Details
File: maps (38.62 KB, text/plain)
2012-06-04 08:10 EDT, Stefan Jensen
no flags Details
File: backtrace (281.47 KB, text/plain)
2012-06-04 08:10 EDT, Stefan Jensen
no flags Details

  None (edit)
Description Stefan Jensen 2012-06-04 08:10:06 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        pan
comment:        This happens from time to time when i try to start pan. If pan was started successfully once while a session, it does not happen. Only first time start will fail (sometimes)
crash_function: _gnutls_x509_crt_get_raw_dn2
executable:     /usr/bin/pan
kernel:         3.3.7-1.fc17.x86_64
pid:            13673
pwd:            /home/jensen
time:           Mo 04 Jun 2012 13:52:22 CEST
uid:            1000
username:       jensen

backtrace:      Text file, 288226 bytes
dso_list:       Text file, 7931 bytes
maps:           Text file, 39547 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/jensen/3

core_backtrace:
:591c7ebbd3f4b573e01caf6e462b01a226faa9cf 0x73e50 - libgnutls.so.26 -
:591c7ebbd3f4b573e01caf6e462b01a226faa9cf 0x3c7db - libgnutls.so.26 -
:591c7ebbd3f4b573e01caf6e462b01a226faa9cf 0x3e5b5 gnutls_certificate_set_x509_trust libgnutls.so.26 -
:39a9c22743835d73e2a5a0e51c1ce70156b4fcc0 0x16e4c3 pan::CertStore::add(gnutls_x509_crt_int*, [exe] -
:39a9c22743835d73e2a5a0e51c1ce70156b4fcc0 0x16ebe0 pan::verify_callback(gnutls_session_int*) [exe] -
:591c7ebbd3f4b573e01caf6e462b01a226faa9cf 0x33d09 - libgnutls.so.26 -
:591c7ebbd3f4b573e01caf6e462b01a226faa9cf 0x26510 - libgnutls.so.26 -
:591c7ebbd3f4b573e01caf6e462b01a226faa9cf 0x22b40 - libgnutls.so.26 -
:591c7ebbd3f4b573e01caf6e462b01a226faa9cf 0x22fa5 gnutls_handshake libgnutls.so.26 -
:39a9c22743835d73e2a5a0e51c1ce70156b4fcc0 0x15e4ad pan::GIOChannelSocketGnuTLS::_gnutls_handshake(_GIOChannel*) [exe] -
:39a9c22743835d73e2a5a0e51c1ce70156b4fcc0 0x15e81c pan::GIOChannelSocketGnuTLS::gnutls_get_iochannel(_GIOChannel*, [exe] -
:39a9c22743835d73e2a5a0e51c1ce70156b4fcc0 0x15ea67 pan::GIOChannelSocketGnuTLS::create_channel(pan::StringView [exe] -
:39a9c22743835d73e2a5a0e51c1ce70156b4fcc0 0x15ed75 pan::GIOChannelSocketGnuTLS::open(pan::StringView [exe] -
:39a9c22743835d73e2a5a0e51c1ce70156b4fcc0 0x15c72d - [exe] -
:39a9c22743835d73e2a5a0e51c1ce70156b4fcc0 0x1a2f8a pan::WorkerPool::Worker::worker_thread_func(void*, [exe] -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x6ab42 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x6a345 - libglib-2.0.so.0 -
:73777e822e00ca152ffca281ab0ace0cb498ec48 0x7d14 start_thread libpthread.so.0 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0xf199d clone libc.so.6 -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=3
:HOSTNAME=hurricane.lounge-warrior.org
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/jensen/keyring-kfKcIo
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=jensen
:USERNAME=jensen
:MAIL=/var/spool/mail/jensen
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/jensen/.local/bin:/home/jensen/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/jensen
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=2033
:LANG=de_DE.utf8
:GDM_LANG=de_DE.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/jensen
:SHLVL=1
:LOGNAME=jensen
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ynu9e44oPR,guid=2fa9a0fcc2766ed02984067f0000002c
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/jensen
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-jensen-P70m2j/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2037,unix/unix:/tmp/.ICE-unix/2037
:GPG_AGENT_INFO=/run/user/jensen/keyring-kfKcIo/gpg:0:1
:SSH_AUTH_SOCK=/run/user/jensen/keyring-kfKcIo/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/fedora-pan.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=13673
:DESKTOP_STARTUP_ID=gnome-shell-2274-hurricane.lounge-warrior.org-pan-26_TIME13767937

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31564                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31564                31564                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/jensen/.xsession-errors
:pos:	20058
:flags:	0102002
:2:/home/jensen/.xsession-errors
:pos:	20058
:flags:	0102002
:3:socket:[59108]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:/dev/urandom
:pos:	0
:flags:	02100000
:6:socket:[60710]
:pos:	0
:flags:	02000002
:7:/home/jensen/.pan2/ssl_certs/reader.albasani.net.pem
:pos:	1428
:flags:	0100000
:8:socket:[59781]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:socket:[59122]
:pos:	0
:flags:	02004002
:12:anon_inode:inotify
:pos:	0
:flags:	02004000
:13:socket:[59140]
:pos:	0
:flags:	02
:14:socket:[59136]
:pos:	0
:flags:	04002
:15:socket:[60722]
:pos:	0
:flags:	02
:16:socket:[60723]
:pos:	0
:flags:	02

var_log_messages:
:Jun  3 20:30:40 hurricane abrt[5714]: Saved core dump of pid 5703 (/usr/bin/pan) to /var/spool/abrt/ccpp-2012-06-03-20:30:39-5703 (68870144 bytes)
:Jun  3 20:30:57 hurricane abrt[5771]: Not dumping repeating crash in '/usr/bin/pan'
:Jun  4 13:52:22 hurricane abrt[13693]: Saved core dump of pid 13673 (/usr/bin/pan) to /var/spool/abrt/ccpp-2012-06-04-13:52:22-13673 (68780032 bytes)
Comment 1 Stefan Jensen 2012-06-04 08:10:12 EDT
Created attachment 589128 [details]
File: dso_list
Comment 2 Stefan Jensen 2012-06-04 08:10:15 EDT
Created attachment 589129 [details]
File: maps
Comment 3 Stefan Jensen 2012-06-04 08:10:22 EDT
Created attachment 589130 [details]
File: backtrace
Comment 4 Petr Kovar 2012-06-05 09:45:54 EDT
Thank you for your report.

Because this problem only occurs with gnutls < 3.0., it will be fixed once gnutls >= 3.0 is packaged for Fedora.

Closing as deferred.

Note You need to log in before you can comment on or make changes to this bug.