Bug 828174 - screen terminates immediately for non-privileged user
screen terminates immediately for non-privileged user
Status: CLOSED DUPLICATE of bug 813607
Product: Fedora
Classification: Fedora
Component: screen (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukáš Nykrýn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 08:15 EDT by Henrik Bakken
Modified: 2012-06-04 08:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 08:51:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrik Bakken 2012-06-04 08:15:38 EDT
Description of problem:

screen fails to start for non-root users after preupgrade from F16 to F17

Version-Release number of selected component (if applicable):

screen-4.1.0-0.9.20120314git3c2946.fc17.x86_64

How reproducible:

Always

Steps to Reproduce:
1. 'screen'
2.
3.
  
Actual results:

screen terminates, printing "screen is terminating".

Expected results:

screen doesn't immediately terminate.

Additional info:

Running screen in e.g. gdb/strace reveals that it prints 'Directory '/var/run/screen' must have mode 777.'.  If manually chmodded to 0777, it prints 'Directory '/var/run/screen' must have mode 775.'.

Turning SELinux off does not help.  Being member of the screen group does not help.  Root can run screen.

Also, when the error occurs _and_ SElinux is turned on, the following appears in audit.log:

              type=ANOM_ABEND msg=audit(1338810943.409:195): auid=500 uid=500 
              gid=1000 ses=2 
              subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 
              pid=3554 comm="screen" reason="memory violation" sig=6
Comment 1 Lukáš Nykrýn 2012-06-04 08:44:04 EDT
Can you please check that your binary has correct permissions?

[lnykryn@dhcp-27-188 ~]$ ls -alh /usr/bin/screen 
-rwxr-sr-x. 1 root screen 429K 26. dub 12.23 /usr/bin/screen

Screen must have setgid to work correctly.
Comment 2 Lukáš Nykrýn 2012-06-04 08:51:15 EDT

*** This bug has been marked as a duplicate of bug 813607 ***
Comment 3 Henrik Bakken 2012-06-04 08:53:08 EDT
Probably a false alarm...

A line in ~/.screenrc:

  setenv TERMINFO /hom/<nonexistentusername>/.terminfo

caused the error.
Comment 4 Henrik Bakken 2012-06-04 08:53:40 EDT
(In reply to comment #1)
> Can you please check that your binary has correct permissions?
> 
> [lnykryn@dhcp-27-188 ~]$ ls -alh /usr/bin/screen 
> -rwxr-sr-x. 1 root screen 429K 26. dub 12.23 /usr/bin/screen
> 
> Screen must have setgid to work correctly.

[14:52:57][hgb@prentice:~]1 ls -alh /usr/bin/screen
-rwxr-sr-x. 1 root screen 422K Mar 28 17:05 /usr/bin/screen

Note You need to log in before you can comment on or make changes to this bug.