Bug 82823 - mail component won't start at all (crashes)
mail component won't start at all (crashes)
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-27 06:19 EST by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-05 10:05:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace with gal and evolution symbols (17.45 KB, text/plain)
2003-01-27 08:19 EST, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2003-01-27 06:19:32 EST
Description of problem:
The mail component no longer starts at all; it just crashes.

Version-Release number of selected component (if applicable):
evolution-1.2.1-4
libgnomeui-2.1.90-3
libgal21-0.22-2
glib-1.2.10-10
gtk+-1.2.10-25
bonobo-1.0.22-2
ORBit-0.5.17-4
glibc-2.3.1-38
kernel-2.4.20-2.26

How reproducible:
100%

Steps to Reproduce:
1. Start evolution.

Backtrace was generated from '/usr/bin/evolution-mail'

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1091430144 (LWP 1645)]
[New Thread 1125293376 (LWP 1690)]
[New Thread 1116904768 (LWP 1687)]
[New Thread 1102789952 (LWP 1686)]
0xffffe002 in ?? ()
#0  0xffffe002 in ?? ()
#1  0x40b6fe4f in gnome_init () from /usr/lib/libgnomeui.so.32
#2  0x080c2549 in message_browser_get_type ()
#3  <signal handler called>
#4  0x4051f7ae in e_tree_memory_thaw () from /usr/lib/libgal.so.21
#5  0x405213d9 in e_tree_model_node_get_first_child ()
   from /usr/lib/libgal.so.21
#6  0x080c509a in message_list_new ()
#7  0x080c76b5 in message_list_hide_clear ()
#8  0x080b07bd in mail_msg_wait_all ()
#9  0x40eec0a6 in g_io_add_watch () from /usr/lib/libglib-1.2.so.0
#10 0x40eed9ae in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#11 0x40eede89 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#12 0x40eee093 in g_main_iteration () from /usr/lib/libglib-1.2.so.0
#13 0x40df9518 in gtk_main_iteration () from /usr/lib/libgtk-1.2.so.0
#14 0x40334cbe in bonobo_control_windowid_from_x11 ()
   from /usr/lib/libbonobox.so.2
#15 0x402e8a5d in _ORBIT_skel_Bonobo_Control_realize ()
   from /usr/lib/libbonobo.so.2
#16 0x40d1e79c in ORBit_POA_handle_request () from /usr/lib/libORBit.so.0
#17 0x40d21339 in ORBit_handle_incoming_request () from /usr/lib/libORBit.so.0
#18 0x40d3a8c6 in giop_recv_reply_buffer_use_multiple_2 ()
   from /usr/lib/libIIOP.so.0
#19 0x40d3a99a in giop_recv_reply_buffer_use_2 () from /usr/lib/libIIOP.so.0
#20 0x402d565f in Bonobo_UIContainer_setNode () from /usr/lib/libbonobo.so.2
#21 0x40340276 in bonobo_ui_component_set () from /usr/lib/libbonobox.so.2
#22 0x4034015f in bonobo_ui_component_set () from /usr/lib/libbonobox.so.2
#23 0x40341481 in bonobo_ui_component_set_prop () from /usr/lib/libbonobox.so.2
#24 0x403412e9 in bonobo_ui_component_set_prop () from /usr/lib/libbonobox.so.2
#25 0x08080ff3 in fbui_sensitise_item ()
#26 0x08081099 in fbui_sensitise_item ()
#27 0x08081179 in folder_browser_ui_scan_selection ()
#28 0x080812d0 in folder_browser_ui_set_selection_state ()
#29 0x0807c8fe in folder_browser_toggle_threads ()
#30 0x4033ef5d in bonobo_socket_set_control_frame ()
   from /usr/lib/libbonobox.so.2
#31 0x40dfb19e in gtk_marshal_NONE__POINTER_INT_POINTER ()
   from /usr/lib/libgtk-1.2.so.0
#32 0x40e3207e in gtk_signal_set_funcs () from /usr/lib/libgtk-1.2.so.0
#33 0x40e2fab2 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#34 0x4033f1e4 in bonobo_socket_set_control_frame ()
   from /usr/lib/libbonobox.so.2
#35 0x402e69a2 in _ORBIT_skel_Bonobo_UIComponent_uiEvent ()
   from /usr/lib/libbonobo.so.2
#36 0x40d1e79c in ORBit_POA_handle_request () from /usr/lib/libORBit.so.0
#37 0x40d21339 in ORBit_handle_incoming_request () from /usr/lib/libORBit.so.0
#38 0x40d3a8c6 in giop_recv_reply_buffer_use_multiple_2 ()
   from /usr/lib/libIIOP.so.0
#39 0x40d3a99a in giop_recv_reply_buffer_use_2 () from /usr/lib/libIIOP.so.0
#40 0x402d565f in Bonobo_UIContainer_setNode () from /usr/lib/libbonobo.so.2
#41 0x40340276 in bonobo_ui_component_set () from /usr/lib/libbonobox.so.2
#42 0x4034015f in bonobo_ui_component_set () from /usr/lib/libbonobox.so.2
#43 0x40341481 in bonobo_ui_component_set_prop () from /usr/lib/libbonobox.so.2
#44 0x403412e9 in bonobo_ui_component_set_prop () from /usr/lib/libbonobox.so.2
#45 0x08080ff3 in fbui_sensitise_item ()
#46 0x08081099 in fbui_sensitise_item ()
#47 0x08081179 in folder_browser_ui_scan_selection ()
#48 0x080812d0 in folder_browser_ui_set_selection_state ()
#49 0x0807e64f in hide_sender ()
#50 0x40dfaff6 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0
#51 0x40e33015 in gtk_signal_remove_emission_hook ()
   from /usr/lib/libgtk-1.2.so.0
#52 0x40e3216d in gtk_signal_set_funcs () from /usr/lib/libgtk-1.2.so.0
#53 0x40e2fab2 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#54 0x404cb5da in e_selection_model_selection_changed ()
   from /usr/lib/libgal.so.21
#55 0x4052407a in e_tree_scrolled_get_type () from /usr/lib/libgal.so.21
#56 0x4052417b in e_tree_scrolled_get_type () from /usr/lib/libgal.so.21
#57 0x40dfae50 in gtk_marshal_NONE__POINTER () from /usr/lib/libgtk-1.2.so.0
#58 0x40e33015 in gtk_signal_remove_emission_hook ()
   from /usr/lib/libgtk-1.2.so.0
#59 0x40e32267 in gtk_signal_set_funcs () from /usr/lib/libgtk-1.2.so.0
#60 0x40e2fab2 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#61 0x40520ba7 in e_tree_model_node_changed () from /usr/lib/libgal.so.21
#62 0x4051ff5f in e_tree_memory_node_insert () from /usr/lib/libgal.so.21
#63 0x080c4f09 in message_list_new ()
#64 0x080c60ac in message_list_set_folder ()
#65 0x0807b94e in folder_browser_paste ()
#66 0x080b4d8a in mail_build_attachment ()
#67 0x080b07bd in mail_msg_wait_all ()
#68 0x40eec0a6 in g_io_add_watch () from /usr/lib/libglib-1.2.so.0
#69 0x40eed9ae in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#70 0x40eede89 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#71 0x40eee124 in g_main_run () from /usr/lib/libglib-1.2.so.0
#72 0x40df927f in gtk_main () from /usr/lib/libgtk-1.2.so.0
#73 0x402f8ffe in bonobo_main () from /usr/lib/libbonobo.so.2
#74 0x080c271a in main ()
#75 0x420154a0 in __libc_start_main () from /lib/tls/libc.so.6
Comment 1 Tim Waugh 2003-01-27 08:19:53 EST
Created attachment 89619 [details]
backtrace with gal and evolution symbols

Here's the backtrace again, this time with gal-debuginfo and
evolution-debuginfo installed.
Comment 2 Tim Waugh 2003-02-03 07:34:42 EST
This is happening less frequently now (no idea why).

It still happens though.  I am on a remote X session on a 10Mbps link; wonder if
that is anything to do with it.

Let me know what other symbols you want.
Comment 3 Tim Waugh 2003-02-05 10:05:46 EST
As mysteriously as it arrived, it now seems to be gone.

Note You need to log in before you can comment on or make changes to this bug.