Bug 82825 - Can't boot newly installed 8.0.93 Phoebe
Can't boot newly installed 8.0.93 Phoebe
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 82826 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-27 07:39 EST by Remy Vidal
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-27 16:38:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remy Vidal 2003-01-27 07:39:51 EST
Description of problem:
I have been trying to get 8.0.93 installed on /dev/hdh1. Installation is fine 
including creation of partition, formatting and file copying.
However, I can't boot from it with either GRUB or lilo, with or without 
adavanced options. Set up is as follows:

/dev/hda has Windoze + Redhat 8.0 off the main IDE controller on the mobo 
chipset.
/dev/hde and /dev/hdg are 2 drives in RAID0 on HPT372 controller on this ABIT 
KR7A-RAID mobo. /dev/hdh is a slave drive on the HPT372 primary channel and is 
non-raided.

Install on /dev/hdh1 is fine. I have tried lilo and GRUB in root sector 
of /dev/hdh1 and MBR on /dev/hda but couldn't ever boot it. Tried to force 
LBA32, no joy.

In the end overwrote 8.0 with 8.0.93 on /dev/hda1. When running from that 
partition, I can mount /dev/hdh1 and all files seem to be there and all is 
fine. Definitely a boot problem.

New /dev/hdh drive is 80GB Maxtor DiamondMax 9 Plus.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Set up as above
2.Reboot
    
Actual results:
Received GRUB HARD DISK ERROR or hangs when trying lilo.
When trying to use lilo to overwrite a MBR on /dev/hda, nothing happens and the 
old MBR is left intact without being replaced.
Marked /dev/hdh as bootable in HPT372 BIOS and try to boot directly from 
ATA133RAID. Get the same results/error messages as trying to boot from /dev/hda.

Expected results:
Should allow to boot from /dev/hdh1

Additional info:
Comment 1 Jeremy Katz 2003-01-27 16:38:39 EST
You have to update /boot/grub/device.map (or change the device order on the
advanced boot loader options screen in anaconda) and rerun grub-install if you
change the order that your BIOS sees the drives in.  Otherwise, grub continues
to assume the old order and will get the error you saw.  Originally, it probably
couldn't be booted because hdh was probably not accessible as a BIOS drive.
Comment 2 Jeremy Katz 2003-01-28 00:58:49 EST
*** Bug 82826 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.