Bug 828275 - Implement control queue and RX filtering using host in NetKVM
Implement control queue and RX filtering using host in NetKVM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Windows
unspecified Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 09:42 EDT by Yan Vugenfirer
Modified: 2013-02-21 05:38 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Using virtio control queue to offload RX filtering to host. Reason: It was implemented in QEMU and Linux driver for a long time and might enhance performance. Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:38:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Vugenfirer 2012-06-04 09:42:52 EDT
Historically RX filtering (multicast, vlan) was implemented in Windows guest driver as we had to pass WHQL and support for those features did not exist in QEMU.

It is time for Windows driver to use existing QEMU features.
Comment 3 Miya Chen 2012-08-16 09:04:19 EDT
Hi Yan, could you please tell us how to verify this bug? Is only multicast&vlan testing in windows enough? Thanks.
Comment 4 Yan Vugenfirer 2012-08-21 07:04:54 EDT
Also run parts of NDIS 6.5 tests in WLK1.6 called "packet filtering" and vlan\priority.
Comment 5 Mike Cao 2012-08-23 23:09:02 EDT
(In reply to comment #4)
> Also run parts of NDIS 6.5 tests in WLK1.6 called "packet filtering" and
> vlan\priority.

FYI . This part is dup of Bug 834174 ,Let's run  multicast&vlan testing in windows only
Comment 6 errata-xmlrpc 2013-02-21 05:38:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.