Bug 828302 - SELinux is preventing /usr/bin/bash from 'execute' accesses on the file /usr/sbin/ldconfig.
Summary: SELinux is preventing /usr/bin/bash from 'execute' accesses on the file /usr/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:fd445cb72751df4f55e71abe30a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-04 14:17 UTC by Jake Jackson
Modified: 2012-06-30 21:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-30 21:50:57 UTC
Type: ---


Attachments (Terms of Use)

Description Jake Jackson 2012-06-04 14:17:15 UTC
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Mon 04 Jun 2012 04:16:57 PM CEST

description:
:SELinux is preventing /usr/bin/bash from 'execute' accesses on the file /usr/sbin/ldconfig.
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If you want to ignore bash trying to execute access the ldconfig file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /usr/bin/bash /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If you believe that bash should be allowed execute access on the ldconfig file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep sh /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:NetworkManager_t:s0
:Target Context                system_u:object_r:ldconfig_exec_t:s0
:Target Objects                /usr/sbin/ldconfig [ file ]
:Source                        sh
:Source Path                   /usr/bin/bash
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           bash-4.2.28-1.fc17.x86_64
:Target RPM Packages           glibc-2.15-37.fc17.x86_64 glibc-2.15-37.fc17.i686
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21
:                              22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    Mon 04 Jun 2012 07:06:07 AM CEST
:Last Seen                     Mon 04 Jun 2012 04:10:38 PM CEST
:Local ID                      bba18a3f-09b8-4f33-933f-2aaecfe3822f
:
:Raw Audit Messages
:type=AVC msg=audit(1338819038.482:37): avc:  denied  { execute } for  pid=869 comm="sh" name="ldconfig" dev="sda1" ino=135330 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:ldconfig_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338819038.482:37): arch=x86_64 syscall=execve success=no exit=EACCES a0=217ce20 a1=217cf20 a2=217be80 a3=18 items=0 ppid=868 pid=869 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=sh exe=/usr/bin/bash subj=system_u:system_r:NetworkManager_t:s0 key=(null)
:
:Hash: sh,NetworkManager_t,ldconfig_exec_t,file,execute
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:

Comment 1 Daniel Walsh 2012-06-04 14:58:38 UTC
Why is networkmanager running ldconfig?

Comment 2 Miroslav Grepl 2012-06-04 15:23:05 UTC
Actually I believe this is caused by wicd. There is another bug with needinfo on this.

Comment 3 Daniel Walsh 2012-06-04 15:24:01 UTC
I guess it is easier to just allow it to execute it,   If it tries to write something then we have a problem.

Comment 4 Miroslav Grepl 2012-06-22 11:06:47 UTC
Fixed in selinux-policy-3.10.0-133.fc17.noarch

Comment 5 Fedora Update System 2012-06-26 21:47:08 UTC
selinux-policy-3.10.0-134.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-134.fc17

Comment 6 Fedora Update System 2012-06-28 03:36:55 UTC
Package selinux-policy-3.10.0-134.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-134.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10008/selinux-policy-3.10.0-134.fc17
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-06-30 21:50:57 UTC
selinux-policy-3.10.0-134.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.