Bug 828368 - [kn] failed pofilter xmltags tests for subscription-manager translations
[kn] failed pofilter xmltags tests for subscription-manager translations
Status: CLOSED DUPLICATE of bug 828365
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-04 13:22 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 17:51:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-04 13:22:48 EDT
Description of problem:
The gnome xmltags were not properly translated for 'ta_IN' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@jsefler-r63-server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:


Steps to Reproduce:
[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/kn/LC_MESSAGES/rhsm.mo -o /usr/share/locale/kn/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t xmltags /usr/share/locale/kn/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-16 03:03-0400\n"
"Last-Translator: shanky <shanky@fedoraproject.org>\n"
"Language-Team: kn_IN <kde-i18n-doc@kde.org>\n"
"Language: kn\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) xmltags: Different XML tags
msgid "Product entitlement certificates <i>valid</i> until %s"
msgstr "ಉತ್ಪನ್ನ ಎಂಟೈಟಲ್ಮೆಂಟ್ ಪ್ರಮಾಣಪತ್ರಗಳು %s ವರೆಗೆ <i>ಸಿಂಧು<i>ವಾಗಿರುತ್ತವೆ."

Actual results:
Shown above

Expected results:

msgid "Product entitlement certificates <i>valid</i> until %s"
msgstr "ಉತ್ಪನ್ನ ಎಂಟೈಟಲ್ಮೆಂಟ್ ಪ್ರಮಾಣಪತ್ರಗಳು %s ವರೆಗೆ <i>ಸಿಂಧು</i>ವಾಗಿರುತ್ತವೆ."

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#xmltags
Comment 5 Sharath Dwaral 2012-06-04 17:51:49 EDT

*** This bug has been marked as a duplicate of bug 828365 ***
Comment 6 Shankar Prasad 2012-06-25 04:02:13 EDT
Fixed the issue in 0.98.x, 0.99.x and 1.0.x

Shankar

Note You need to log in before you can comment on or make changes to this bug.