Bug 828448 - cannot install both 32-bit and 64-bit glib2-devel due to conflicts
cannot install both 32-bit and 64-bit glib2-devel due to conflicts
Status: CLOSED DUPLICATE of bug 718404
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
17
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 14:25 EDT by Dwayne Fontenot
Modified: 2012-08-14 10:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 10:41:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dwayne Fontenot 2012-06-04 14:25:52 EDT
Description of problem:

Attempting to install both i686 and x86_64 F17 versions of glib2-devel fails due to conflicts.

Version-Release number of selected component (if applicable):

glib2-devel-2.32.3-1.fc17.i686 and glib2-devel-2.32.3-1.fc17.x86_64

How reproducible:

always.

Steps to Reproduce:
1. sudo yum update glib2-devel
2.
3.
  
Actual results:

Transaction Check Error:
  file /usr/bin/gdbus-codegen conflicts between attempted installs of glib2-devel-2.32.3-1.fc17.i686 and glib2-devel-2.32.3-1.fc17.x86_64
  file /usr/share/glib-2.0/gdb/glib.pyc conflicts between attempted installs of glib2-devel-2.32.3-1.fc17.i686 and glib2-devel-2.32.3-1.fc17.x86_64
  file /usr/share/glib-2.0/gdb/glib.pyo conflicts between attempted installs of glib2-devel-2.32.3-1.fc17.i686 and glib2-devel-2.32.3-1.fc17.x86_64
  file /usr/share/glib-2.0/gdb/gobject.pyc conflicts between attempted installs of glib2-devel-2.32.3-1.fc17.i686 and glib2-devel-2.32.3-1.fc17.x86_64
  file /usr/share/glib-2.0/gdb/gobject.pyo conflicts between attempted installs of glib2-devel-2.32.3-1.fc17.i686 and glib2-devel-2.32.3-1.fc17.x86_64
  file /usr/share/systemtap/tapset/glib.stp conflicts between attempted installs of glib2-devel-2.32.3-1.fc17.i686 and glib2-devel-2.32.3-1.fc17.x86_64
  file /usr/share/systemtap/tapset/gobject.stp conflicts between attempted installs of glib2-devel-2.32.3-1.fc17.i686 and glib2-devel-2.32.3-1.fc17.x86_64


Expected results:

Both packages would install, as with versions glib2-2.32.1-1.fc17.x86_64 and 
glib2-2.32.1-1.fc17.i686

Additional info:
Comment 1 Dwayne Fontenot 2012-07-23 12:39:19 EDT
Bug still here in
glib2-devel-2.32.4-1.fc17.i686.rpm and glib2-devel-2.32.4-1.fc17.x86_64.rpm
Comment 2 Nils Philippsen 2012-08-14 10:41:54 EDT

*** This bug has been marked as a duplicate of bug 718404 ***

Note You need to log in before you can comment on or make changes to this bug.