Bug 828452 - system-config-network is a symbolic link to consolehelper, rather than to nm-connection-editor
system-config-network is a symbolic link to consolehelper, rather than to nm-...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
17
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 14:31 EDT by aditya
Modified: 2012-06-05 05:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 05:17:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aditya 2012-06-04 14:31:46 EDT
Description of problem:
To configure a DSL connection system-config-network cannot be used. It opens consolehelper tool with empty device list. After some time i discovered nm-connection-editor is the program to configure DSL.

Version-Release number of selected component (if applicable):
version shipped with Fedora 17 release package.

How reproducible:
100%

Steps to Reproduce:
1.  ls -l /usr/bin/system-config-network
2. result: "/usr/bin/system-config-network -> consolehelper"
3. >system-config-network, opens a console utility with empty device list.
  
Actual results:
running system-config-network opens consolehelper utility.

Expected results:
running system-config-network should open nm-connection-editor utility.

Additional info:
Fresh Fedora 17 installation from DVD iso.
Comment 1 Jiri Popelka 2012-06-05 05:17:37 EDT
AFAIK the GUI (install system-config-network package, not just system-config-network-tui) should be able to configure DSL.
You are right that nm-connection-editor is its successor and that's the reason why we've deprecated system-config-network in rawhide (Fedora-18).

Closing as WONTFIX, thanks for your idea anyway.

Note You need to log in before you can comment on or make changes to this bug.