Bug 828455 - rpmdev-newspec should use %make_install
rpmdev-newspec should use %make_install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmdevtools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 14:34 EDT by Rahul Sundaram
Modified: 2012-09-17 19:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:49:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2012-06-04 14:34:18 EDT
Description of problem:

The default template uses the expanded definition instead of %make_install.   Details at https://fedorahosted.org/fpc/ticket/183.  You can wait till the draft is approved before making this change if you prefer.
Comment 1 Ville Skyttä 2012-06-04 15:35:40 EDT
I don't think changing to use that would be an improvement at the moment.  The vast majority of Fedora packages use the expanded definition anyway, and starting to use the macro would create an unnecessary incompatibility with rpm < 4.8.0 (EPEL 5).
Comment 2 Rahul Sundaram 2012-06-04 16:37:51 EDT
I think you should change the template based on which os it is being run from.  This also applies to %clean etc for example.
Comment 3 Ville Skyttä 2012-06-04 17:33:37 EDT
Not based on that, but based on what -r/--rpm-version is set to.  Since we do have this feature after all, done upstream:

http://git.fedorahosted.org/git/?p=rpmdevtools.git;a=commitdiff;h=9f4736665d84ee683565532fa52a31e695252d87
Comment 4 Rahul Sundaram 2012-06-05 00:59:49 EDT
Thank you so much.
Comment 5 Rahul Sundaram 2012-06-05 01:03:27 EDT
Note that the comment is wrong.  you are using %make_install and not %makeinstall.
Comment 6 Ville Skyttä 2012-06-05 02:32:57 EDT
Fixed, thanks.
Comment 7 Fedora Update System 2012-09-02 17:25:09 EDT
rpmdevtools-8.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rpmdevtools-8.3-1.fc18
Comment 8 Fedora Update System 2012-09-02 17:26:00 EDT
rpmdevtools-8.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rpmdevtools-8.3-1.fc17
Comment 9 Fedora Update System 2012-09-02 17:26:53 EDT
rpmdevtools-8.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rpmdevtools-8.3-1.fc16
Comment 10 Fedora Update System 2012-09-03 13:22:37 EDT
Package rpmdevtools-8.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpmdevtools-8.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13208/rpmdevtools-8.3-1.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-09-11 20:24:31 EDT
rpmdevtools-8.3-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-09-11 20:33:46 EDT
rpmdevtools-8.3-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-09-17 19:49:51 EDT
rpmdevtools-8.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.