Bug 828481 - [abrt] python-2.7.3-3.fc16: g_hash_table_iter_next: Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
[abrt] python-2.7.3-3.fc16: g_hash_table_iter_next: Process /usr/bin/python2....
Status: CLOSED DUPLICATE of bug 825292
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:de45a5deb880e46ce28ce458515...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 15:19 EDT by jackie
Modified: 2012-06-09 15:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-09 15:59:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (11.44 KB, text/plain)
2012-06-04 15:19 EDT, jackie
no flags Details
File: build_ids (4.20 KB, text/plain)
2012-06-04 15:19 EDT, jackie
no flags Details
File: maps (48.58 KB, text/plain)
2012-06-04 15:19 EDT, jackie
no flags Details
File: backtrace (27.46 KB, text/plain)
2012-06-04 15:19 EDT, jackie
no flags Details

  None (edit)
Description jackie 2012-06-04 15:19:15 EDT
libreport version: 2.0.10
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/python2.7 -OOt /usr/bin/alacarte
crash_function: g_hash_table_iter_next
executable:     /usr/bin/python2.7
kernel:         3.3.7-1.fc16.x86_64
pid:            8723
pwd:            /home/lorg
time:           Tue 05 Jun 2012 02:18:28 AM ICT
uid:            1000
username:       lorg
var_log_messages: Jun  5 02:18:29 jackie abrt[8728]: Saved core dump of pid 8723 (/usr/bin/python2.7) to /var/spool/abrt/ccpp-2012-06-05-02:18:28-8723 (16650240 bytes)

backtrace:      Text file, 28115 bytes
build_ids:      Text file, 4305 bytes
dso_list:       Text file, 11716 bytes
maps:           Text file, 49743 bytes

environ:
:XDG_VTNR=2
:XDG_SESSION_ID=5
:HOSTNAME=jackie.lorg
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=65e30c7f275b467c3577831800000010-1338831376.35890-958420254
:GNOME_KEYRING_CONTROL=/tmp/keyring-LpoJWh
:IMSETTINGS_MODULE=IBus
:USER=lorg
:USERNAME=lorg
:MAIL=/var/spool/mail/lorg
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/lorg/.local/bin:/home/lorg/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/lorg
:XMODIFIERS=@im=ibus
:GNOME_KEYRING_PID=3658
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/lorg
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=lorg
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-zPicoDv9nO,guid=494bdf92003f15851e52597300001354
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/lorg
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-lorg-hYDkue/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/3662,unix/unix:/tmp/.ICE-unix/3662
:SSH_AUTH_SOCK=/tmp/keyring-LpoJWh/ssh
:GPG_AGENT_INFO=/tmp/keyring-LpoJWh/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:DESKTOP_STARTUP_ID=gnome-shell-3807-jackie.lorg-alacarte-22_TIME11045648
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/alacarte.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=8723

smolt_data:
:
:
:General
:=================================
:UUID: 42de1433-b34f-45cc-9b84-a148a31bc5c5
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4787.83
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2401
:System Memory: 3855
:System Swap: 5919
:Vendor: Hewlett-Packard
:System: HP EliteBook 6930p F.12
:Form factor: Notebook
:Kernel: 3.3.7-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10816:4156:12507) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10536:4156:12507) pci, ata_piix, STORAGE, ICH9M/M-E 2 port SATA IDE Controller
:(32902:10519:4156:12507) pci, None, PCI/ISA, ICH9M-E LPC Interface Controller
:(32902:10541:4156:12507) pci, ata_piix, STORAGE, ICH9M/M-E 2 port SATA IDE Controller
:(32902:4341:4156:12507) pci, e1000e, ETHERNET, 82567LM Gigabit Network Connection
:(32902:16946:32902:4609) pci, iwlwifi, NETWORK, WiFi Link 5100 AGN
:(32902:10549:4156:12507) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:9288:0:0) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10553:4156:12507) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4156:12507) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:4156:12507) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4156:12507) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10818:4156:12507) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:4156:12507) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10568:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:4156:12507) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10548:4156:12507) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(4480:1142:4156:12507) pci, yenta_cardbus, PCI/CARDBUS, RL5c476 II
:(4480:2115:4156:12507) pci, sdhci-pci, BASE, R5C843 MMC Host Controller
:(4480:2082:4156:12507) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(32902:10551:4156:12507) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4156:12507) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_jackie-lv_root / ext4 4096 4096 11093653 8844276 8288449 2779840 2595036 2595036
:/dev/sda7 /boot ext4 1024 1024 508745 410159 384559 128016 127785 127785
:/dev/sda5 WITHHELD fuseblk 4096 4096 38792491 13778210 13778210 55243912 55136872 55136872
:/dev/sda1 WITHHELD fuseblk 4096 4096 12799780 5042905 5042905 20335460 20223194 20223194
:

xsession_errors:
:/usr/lib64/python2.7/site-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
:  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 371, in on_item_tree_show_toggled
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 182, in setVisible
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 441, in writeItem
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 427, in makeKeyFile
:  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 371, in on_item_tree_show_toggled
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 182, in setVisible
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 441, in writeItem
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 427, in makeKeyFile
:  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 371, in on_item_tree_show_toggled
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 182, in setVisible
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 441, in writeItem
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 427, in makeKeyFile
:  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 371, in on_item_tree_show_toggled
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 182, in setVisible
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 441, in writeItem
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 427, in makeKeyFile
:  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 371, in on_item_tree_show_toggled
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 182, in setVisible
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 441, in writeItem
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 427, in makeKeyFile
:  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 371, in on_item_tree_show_toggled
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 182, in setVisible
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 441, in writeItem
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 427, in makeKeyFile
:  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 371, in on_item_tree_show_toggled
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 182, in setVisible
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 441, in writeItem
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 427, in makeKeyFile
:  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 371, in on_item_tree_show_toggled
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 182, in setVisible
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 441, in writeItem
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 427, in makeKeyFile
:  File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 371, in on_item_tree_show_toggled
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 182, in setVisible
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 441, in writeItem
:  File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 427, in makeKeyFile
Comment 1 jackie 2012-06-04 15:19:21 EDT
Created attachment 589254 [details]
File: dso_list
Comment 2 jackie 2012-06-04 15:19:23 EDT
Created attachment 589255 [details]
File: build_ids
Comment 3 jackie 2012-06-04 15:19:26 EDT
Created attachment 589256 [details]
File: maps
Comment 4 jackie 2012-06-04 15:19:29 EDT
Created attachment 589257 [details]
File: backtrace
Comment 5 Thomas Spura 2012-06-09 15:59:54 EDT
Thanks for the bug report.

This looks like the same bug as described in #828481:
#0  0x00000034182333a4 in g_hash_table_iter_next (iter=0x7fff443d3a00, key=0x0, value=0x7fff443d3a28) at ghash.c:762
        ri = 0x7fff443d3a00
        position = 0
        __PRETTY_FUNCTION__ = "g_hash_table_iter_next"
#1  0x0000003420cd508f in garbage_collect_cell_data (data=0x1a75a50) at gtktreeviewaccessible.c:2842
        accessible = 0x1a75a50
        cell_info = 0x341826bc0a
        iter = {dummy1 = 0x1a10400, dummy2 = 0x0, dummy3 = 0x1, dummy4 = -1, dummy5 = 52, dummy6 = 0x3400000000}
#2  0x0000003420cd50fd in idle_garbage_collect_cell_data (data=0x1a75a50) at gtktreeviewaccessible.c:2866
        accessible = 0x1a75a50
#3  0x0000003421e1a38f in gdk_threads_dispatch (data=0x1a6d380) at gdk.c:754
        dispatch = 0x1a6d380

Reassigning to gtk3 and closing as a dub of that bug.

*** This bug has been marked as a duplicate of bug 825292 ***

Note You need to log in before you can comment on or make changes to this bug.