This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 828516 - [abrt] libreoffice-core-3.5.3.2-3.fc17: _XIOError -> FontSubstConfiguration dtor: killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.3.2-3.fc17: _XIOError -> FontSubstConfiguration d...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:b17c2195a61788e67b9c2a52c74...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 16:13 EDT by Matthieu Pupat
Modified: 2012-06-05 07:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 07:06:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: build_ids (8.09 KB, text/plain)
2012-06-04 16:13 EDT, Matthieu Pupat
no flags Details
File: maps (94.34 KB, text/plain)
2012-06-04 16:14 EDT, Matthieu Pupat
no flags Details
File: backtrace (39.21 KB, text/plain)
2012-06-04 16:14 EDT, Matthieu Pupat
no flags Details

  None (edit)
Description Matthieu Pupat 2012-06-04 16:13:53 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin -writer --splash-pipe=6
crash_function: __GI_exit
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.3.7-1.fc17.x86_64
pid:            3017
pwd:            /home/matthieu
time:           Sun 03 Jun 2012 09:37:10 PM CEST
uid:            1000

backtrace:      Text file, 40156 bytes
build_ids:      Text file, 8282 bytes
maps:           Text file, 96602 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/matthieu/2

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=puitepee.trolls.pupat-ghestem.net
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=3002
:GPG_AGENT_INFO=/run/user/matthieu/keyring-aIT6ZP/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=gnome-panel-2008-puitepee.trolls.pupat-ghestem.net-libreoffice-7_TIME1726054
:HISTSIZE=1000
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/run/user/matthieu/keyring-aIT6ZP
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=matthieu
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64:/home/matthieu/kde/lib64:
:SSH_AUTH_SOCK=/run/user/matthieu/keyring-aIT6ZP/ssh
:USERNAME=matthieu
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1743,unix/unix:/tmp/.ICE-unix/1743
:GIO_LAUNCHED_DESKTOP_FILE=/home/matthieu/.local/share/applications/libreoffice-writer.desktop
:MAIL=/var/spool/mail/matthieu
:PATH=/usr/lib64/ccache:/home/matthieu/kde/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/matthieu/bin:/home/matthieu/sources/android/android-sdk-linux:/home/matthieu/sources/android/android-sdk-linux/tools:/home/matthieu/sources/android/android-sdk-linux/platform-tools
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/matthieu
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=1739
:LANG=en_US.UTF-8
:CVSREAD=1
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/matthieu
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=matthieu
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-pYylkNYz5F,guid=f6a1f742921e462b433c57db0000005d
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/matthieu
:DISPLAY=:0.0
:XAUTHORITY=/var/run/gdm/auth-for-matthieu-P8M3mD/database

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 59184                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       59184                59184                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/matthieu/.xsession-errors
:pos:	443334
:flags:	0102002
:2:/home/matthieu/.xsession-errors
:pos:	443334
:flags:	0102002
:3:socket:[119323]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:pipe:[120181]
:pos:	0
:flags:	00
:6:pipe:[120181]
:pos:	0
:flags:	01
:7:socket:[119324]
:pos:	0
:flags:	02000002
Comment 1 Matthieu Pupat 2012-06-04 16:13:58 EDT
Created attachment 589272 [details]
File: build_ids
Comment 2 Matthieu Pupat 2012-06-04 16:14:01 EDT
Created attachment 589273 [details]
File: maps
Comment 3 Matthieu Pupat 2012-06-04 16:14:03 EDT
Created attachment 589274 [details]
File: backtrace
Comment 4 Caolan McNamara 2012-06-05 07:06:54 EDT
An unexpected XIOError leading to FontSubstConfiguration shutdown and a crash during that. Odd thing is that the dtors seem to be called from thread 3 and not thread 1 as I'd expect. Don't really know what that is.

Anyway, we can't survive an XIOError (x server connection gone away) so while it'd be nicer to have a cleaner shutdown on disconnect its not a serious problem in the absence of an easy-fix.
Comment 5 Stephan Bergmann 2012-06-05 07:38:13 EDT
(In reply to comment #4)
> Odd thing is that the dtors seem to be called from thread
> 3 and not thread 1 as I'd expect. Don't really know what that is.

Looks like both the main thread (reported as thread #3) and the SelectionManager thread (reported as thread #1) raced for _XIOError -> ... -> __run_exit_handlers, and the main thread happened to win.

Note You need to log in before you can comment on or make changes to this bug.