Bug 828522 - dhcpd should drop a dispatcher script into /etc/NetworkManager/dispatcher.d
dhcpd should drop a dispatcher script into /etc/NetworkManager/dispatcher.d
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 16:30 EDT by Serge Pavlovsky
Modified: 2012-06-17 18:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-17 18:23:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Serge Pavlovsky 2012-06-04 16:30:15 EDT
Description of problem:

Jun  5 00:14:12 underdark dhcpd: Internet Systems Consortium DHCP Server 4.2.4rc1
Jun  5 00:14:12 underdark dhcpd: Copyright 2004-2012 Internet Systems Consortium.
Jun  5 00:14:12 underdark dhcpd: All rights reserved.
Jun  5 00:14:12 underdark dhcpd: For info, please visit https://www.isc.org/software/dhcp/
...
Jun  5 00:14:12 underdark dhcpd: Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
Jun  5 00:14:12 underdark dhcpd: Wrote 0 deleted host decls to leases file.
Jun  5 00:14:12 underdark dhcpd: Wrote 0 new dynamic host decls to leases file.
Jun  5 00:14:12 underdark dhcpd: Wrote 0 leases to leases file.
...
Jun  5 00:14:12 underdark dhcpd: 
Jun  5 00:14:12 underdark dhcpd: No subnet declaration for virbr0 (192.168.122.1).
Jun  5 00:14:12 underdark dhcpd: ** Ignoring requests on virbr0.  If this is not what
Jun  5 00:14:12 underdark dhcpd:    you want, please write a subnet declaration
Jun  5 00:14:12 underdark dhcpd:    in your dhcpd.conf file for the network segment
Jun  5 00:14:12 underdark dhcpd:    to which interface virbr0 is attached. **
Jun  5 00:14:12 underdark dhcpd: 
Jun  5 00:14:12 underdark dhcpd: 
Jun  5 00:14:12 underdark dhcpd: No subnet declaration for eth1 (no IPv4 addresses).
Jun  5 00:14:12 underdark dhcpd: ** Ignoring requests on eth1.  If this is not what
Jun  5 00:14:12 underdark dhcpd:    you want, please write a subnet declaration
Jun  5 00:14:12 underdark dhcpd:    in your dhcpd.conf file for the network segment
Jun  5 00:14:12 underdark dhcpd:    to which interface eth1 is attached. **
Jun  5 00:14:12 underdark dhcpd: 
Jun  5 00:14:12 underdark dhcpd: 
Jun  5 00:14:12 underdark dhcpd: No subnet declaration for p9p1 (no IPv4 addresses).
Jun  5 00:14:12 underdark dhcpd: ** Ignoring requests on p9p1.  If this is not what
Jun  5 00:14:12 underdark dhcpd:    you want, please write a subnet declaration
Jun  5 00:14:12 underdark dhcpd:    in your dhcpd.conf file for the network segment
Jun  5 00:14:12 underdark dhcpd:    to which interface p9p1 is attached. **
Jun  5 00:14:12 underdark dhcpd: 
Jun  5 00:14:12 underdark dhcpd: 
Jun  5 00:14:12 underdark dhcpd: Not configured to listen on any interfaces!
Jun  5 00:14:12 underdark dhcpd: 
Jun  5 00:14:13 underdark dhcpd: This version of ISC DHCP is based on the release available
Jun  5 00:14:13 underdark dhcpd: on ftp.isc.org.  Features have been added and other changes
Jun  5 00:14:13 underdark dhcpd: have been made to the base software release in order to make
Jun  5 00:14:13 underdark dhcpd: it work better with this distribution.
Jun  5 00:14:13 underdark dhcpd: 
Jun  5 00:14:13 underdark dhcpd: Please report for this software via the Red Hat Bugzilla site:
Jun  5 00:14:13 underdark dhcpd:     http://bugzilla.redhat.com
Jun  5 00:14:13 underdark dhcpd: 
Jun  5 00:14:13 underdark dhcpd: exiting.
...
Jun  5 00:14:13 underdark systemd[1]: dhcpd.service: main process exited, code=exited, status=1
Jun  5 00:14:13 underdark systemd[1]: Unit dhcpd.service entered failed state.
...
Jun  5 00:14:15 underdark kernel: [   27.634581] r8169 0000:03:00.0: p9p1: link up
Jun  5 00:14:15 underdark kernel: [   27.635444] ADDRCONF(NETDEV_CHANGE): p9p1: link becomes ready
Jun  5 00:14:15 underdark NetworkManager[829]: <info> (p9p1): carrier now ON (device state 20)
Jun  5 00:14:15 underdark NetworkManager[829]: <info> (p9p1): device state change: unavailable -> disconnected (reason 'carrier-changed') [20 30 40]
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Auto-activating connection 'home'.
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) starting connection 'home'
Jun  5 00:14:15 underdark NetworkManager[829]: <info> (p9p1): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) Stage 1 of 5 (Device Prepare) scheduled...
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) Stage 1 of 5 (Device Prepare) started...
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) Stage 2 of 5 (Device Configure) scheduled...
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) Stage 1 of 5 (Device Prepare) complete.
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) Stage 2 of 5 (Device Configure) starting...
Jun  5 00:14:15 underdark NetworkManager[829]: <info> (p9p1): device state change: prepare -> config (reason 'none') [40 50 0]
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) Stage 2 of 5 (Device Configure) successful.
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) Stage 3 of 5 (IP Configure Start) scheduled.
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) Beginning IP6 addrconf.
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) Stage 3 of 5 (IP Configure Start) complete.
Jun  5 00:14:15 underdark NetworkManager[829]: <info> Activation (p9p1) Stage 5 of 5 (IPv4 Commit) started...
Jun  5 00:14:15 underdark avahi-daemon[796]: Joining mDNS multicast group on interface p9p1.IPv4 with address 192.168.23.6.
Jun  5 00:14:15 underdark avahi-daemon[796]: New relevant interface p9p1.IPv4 for mDNS.
Jun  5 00:14:15 underdark avahi-daemon[796]: Registering new address record for 192.168.23.6 on p9p1.IPv4.
------------
# grep 192.168.23.0 /etc/dhcp/dhcpd.conf 
subnet 192.168.23.0 netmask 255.255.255.0 {


as you can see, dhcpd starts too early and dies before interface is up

at least it must support IP_FREEBIND, but socket activation is also nice
Comment 1 Jiri Popelka 2012-06-05 05:42:02 EDT
Work-around:
systemctl enable NetworkManager-wait-online.service
Comment 2 Jiri Popelka 2012-06-05 06:40:40 EDT
Oh, I see what's going on.
I prematurely removed the NetworkManager dispatcher script (bug #565921) few months ago because I was hoping it's not needed anymore.
I've just returned it back as it was obviously a mistake.
Comment 3 Jiri Popelka 2012-06-05 06:47:22 EDT
I'm changing this BZ's summary as we are not going to fix this in your proposed way atm (it's not viable to push this upstream).
Comment 4 Fedora Update System 2012-06-05 06:55:33 EDT
dhcp-4.2.4-0.8.rc2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dhcp-4.2.4-0.8.rc2.fc17
Comment 5 Fedora Update System 2012-06-07 18:52:40 EDT
Package dhcp-4.2.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dhcp-4.2.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8999/dhcp-4.2.4-1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-06-17 18:23:31 EDT
dhcp-4.2.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.