Bug 828533 - katello agent AMQP port does not match /etc/services
katello agent AMQP port does not match /etc/services
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Bryan Kearney
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 16:51 EDT by Mike McCune
Modified: 2014-09-18 11:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
CloudForms System Engine client agent communicated with the Advanced Message Queuing Protocol (AMQP) over port 5674. This port changed to 5671 in System Engine 1.1. This patch corrects the port settings in the client and server configuration files.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 10:22:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2012-06-04 16:51:52 EDT
katello's amqp and the agent communicate over 5674 yet /etc/services indicates this should be on 5671. 

We should correct our port usage to 5761 to correctly follow the standard port as indicated in /etc/services
Comment 1 Lukas Zapletal 2012-06-13 04:33:46 EDT
Note: Before doing this please upgrade to the latest AMQP and make sure this was not already fixed in RHEL.

Btw since we use default SSL port it could be good idea to move this upstream.
Comment 3 Lukas Zapletal 2012-06-22 08:21:40 EDT
Ah I did not follow Mike's report. Now I understand. Please disregard comment 1. We are using wrong port!

# grep amqp /etc/services
amqps           5671/tcp                # amqp protocol over TLS/SSL
amqps           5671/udp                # amqp protocol over TLS/SSL
amqp            5672/tcp                # AMQP
amqp            5672/udp                # AMQP
amqp            5672/sctp               # AMQP

Correcting https://fedorahosted.org/katello/wiki/FirewallConfiguration

https://github.com/Katello/katello/pull/231
Comment 5 Og Maciel 2012-09-17 19:00:53 EDT
Client:  katello-agent-1.1.2-1.el6cf.noarch

* /etc/gofer/plugins/katelloplugin.conf

  [messaging]
  uuid=
  url=ssl://$(host):5671
  cacert=/etc/rhsm/ca/candlepin-local.pem
  clientcert=/etc/pki/consumer/bundle.pem

Server:

* /etc/qpidd.conf
  auth=no
  require-encryption=yes
  ssl-require-client-authentication=yes
  ssl-port=5671
  ssl-cert-db=/etc/pki/katello/nssdb
  ssl-cert-password-file=/etc/katello/nss_db_password-file
  ssl-cert-name=broker

* /etc/pulp/pulp.conf
  [messaging]
  url:        ssl://localhost:5671
  cacert:     /usr/share/katello/candlepin-cert.crt
  clientcert: /etc/pki/pulp/qpid_client_striped.crt
Comment 6 Og Maciel 2012-09-17 19:10:00 EDT
Verified using:

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-7.el6cf.noarch
* katello-all-1.1.12-7.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-4.el6cf.noarch
* katello-cli-common-1.1.8-4.el6cf.noarch
* katello-common-1.1.12-7.el6cf.noarch
* katello-configure-1.1.9-3.el6cf.noarch
* katello-glue-candlepin-1.1.12-7.el6cf.noarch
* katello-glue-pulp-1.1.12-7.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 7 Mike McCune 2012-10-24 10:22:10 EDT
closing, currentrelease since these seemingly got missed in the 1.0.1 errata
Comment 8 Mike McCune 2013-08-16 14:18:32 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.