Bug 828605 - New translations are not picked up by TM
New translations are not picked up by TM
Status: CLOSED DUPLICATE of bug 835457
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.5
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
https://translate.engineering.redhat....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 21:03 EDT by Hedda Peters
Modified: 2013-03-03 21:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 01:19:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-06-04 21:03:22 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build Identifier: 

It seems that new translations are not being picked up by the translation memory. We noticed on the string "Important Terms", which appears twice in the current project, 
1) https://translate.engineering.redhat.com/webtrans/Application.html?project=sam&iteration=1.1&localeId=de&locale=de#view:doc;doc:Installation 
2) https://translate.engineering.redhat.com/webtrans/Application.html?project=sam&iteration=1.1&localeId=de&locale=de#view:doc;doc:Administration 

We translated this string in document 1), but when coming across this string again in document 2) there was no TM result for it.


Reproducible: Always

Steps to Reproduce:
1. translate "important terms" in Installation.po (see link above)
2. change to Administration.po (see link above)
3. click into the string "important terms"
Actual Results:  
No 100% TM result 

Expected Results:  
There should be a 100% TM result from the previous translated po-file.

Zanata version 1.5.0 (20120405-0130).
Comment 1 Noriko Mizumoto 2012-06-04 21:13:01 EDT
Just to confirm, this happened to Japanese as well.

https://translate.engineering.redhat.com/webtrans/Application.html?project=rhel-storage-admin-guide&iteration=6.3&localeId=ja&locale=en#view:doc;doc:volume_key-organization
1) Translated term of "For all examples in this file, <filename>/path/to/volume</filename> is a LUKS device, not the plaintext device contained within; <command>blkid -s <replaceable>type</replaceable> <filename><replaceable>/path/to/volume</replaceable></filename></command> should report <computeroutput><replaceable>type</replaceable>="crypto_LUKS"</computeroutput>." does not come up.

https://translate.engineering.redhat.com/webtrans/Application.html?project=cloud_engine_user_guide&iteration=1.0&localeId=ja&locale=en#view:doc;doc:topics/Tasks/Cloud/CF_Instances_Reboot
2) The translation for "Task Summary" has been updated, but old translation still comes up.
Comment 2 Runa Bhattacharjee 2012-06-19 10:05:20 EDT
Hi Hedda, Do you stil lsee this happening for 1.6? Thanks.
Comment 3 Hedda Peters 2012-06-19 21:50:41 EDT
Hi Runa, seems fixed in 1.6! 
Thank you!
Comment 4 Wei Liu 2012-07-01 20:55:11 EDT
Hi Runa,

I still experience this issue on Zanata 1.6. I am working on RHEV 3.1 Installation Guide, and the translation still can't be reflected in TM.
Comment 5 Sean Flanigan 2012-07-03 01:19:33 EDT
We think the problem seen in Zanata 1.5 was caused by disk space exhaustion while indexing.  The issue in Zanata 1.6 was probably caused by running out of memory while indexing.  Let us know if you see this problem in Zanata 1.6.1.

*** This bug has been marked as a duplicate of bug 835457 ***
Comment 6 Hedda Peters 2012-07-03 01:37:09 EDT
No Sean, unfortunately it's still happening on 1.6.1 :-(

Same for search & replace function not working which you said may be related.

Note You need to log in before you can comment on or make changes to this bug.