Bug 828669 - Fedora Project Doesn't Have Online Man Pages Archive
Fedora Project Doesn't Have Online Man Pages Archive
Status: CLOSED WONTFIX
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: eric@christensenplace.us
Fedora Documentation Project
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 03:24 EDT by Ma Hsiao-chun
Modified: 2012-06-05 14:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 10:28:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma Hsiao-chun 2012-06-05 03:24:57 EDT
Online Man Pages Archive Examples:
http://manpages.debian.net/cgi-bin/man.cgi
http://www.freebsd.org/cgi/man.cgi
http://manpages.ubuntu.com/

I tried searching similar stuff for Fedora.
What I saw is the following site:
http://linuxmanpages.net/

Its style is in Fedora flavor.

However:
It contains ADs.
It doesn't have any contact information.
It doesn't have F17 stuff yet.
Its F16 link in homepage is pointing to F15 stuff.

So I think Fedora Project could set up its own online man pages archive.
The domain can be manpages.fedoraproject.org or something.

Thank you in advance.
Comment 1 eric@christensenplace.us 2012-06-05 07:37:26 EDT
I'm not sure how feasible this would be.  Fedora doesn't in any way manage the upstream man pages.  I guess it could be a simple enough task to publish if there was a simple way to obtain all the man pages for a release.
Comment 2 eric@christensenplace.us 2012-06-05 07:52:31 EDT
I've added this to the weekly Docs meeting: https://fedoraproject.org/wiki/Docs_Project_meetings#Agenda_for_Next_Meeting.
Comment 3 eric@christensenplace.us 2012-06-05 10:28:56 EDT
The site http://linuxmanpages.net/ is not a part of Fedora.  We've escalated that part to Legal.

Because Fedora is a collection of upstream projects it isn't very feasible for us to provide man pages online as there are no good ways to automatically parse/update this information.  As you have already discovered there are already several online resources providing this information and since the man pages are shipped with the source they are immediately available on your computer when you install the software.

At this time, the Docs Project declines to add this project to our existing work load.
Comment 4 Jason Brooks 2012-06-05 14:27:31 EDT
For reference, Debian has a man pages site like this at http://manpages.debian.net, the makeup of which is described at http://lists.debian.org/debian-services-admin/2011/08/msg00003.html.

Note You need to log in before you can comment on or make changes to this bug.